summaryrefslogtreecommitdiff
path: root/sys-fs
diff options
context:
space:
mode:
authorDaniel Nagy <danielnagy@gmx.de>2012-02-09 22:09:51 +0100
committerDaniel Nagy <danielnagy@gmx.de>2012-02-09 22:09:51 +0100
commit9842e14f39fc6275c241229843d95fd46706f83a (patch)
tree19e47d47314aacaddef782f4c7d6c09477f40cd5 /sys-fs
parentadding boost dependency to curlpp (diff)
downloaddrevilt-9842e14f39fc6275c241229843d95fd46706f83a.tar.gz
drevilt-9842e14f39fc6275c241229843d95fd46706f83a.tar.bz2
drevilt-9842e14f39fc6275c241229843d95fd46706f83a.zip
adding json-java, parallel-ant, hamlpy, ws4py, iwatch, owncloud
Diffstat (limited to 'sys-fs')
-rw-r--r--sys-fs/iwatch/Manifest2
-rw-r--r--sys-fs/iwatch/iwatch-0.2.2.ebuild42
2 files changed, 44 insertions, 0 deletions
diff --git a/sys-fs/iwatch/Manifest b/sys-fs/iwatch/Manifest
new file mode 100644
index 0000000..477677b
--- /dev/null
+++ b/sys-fs/iwatch/Manifest
@@ -0,0 +1,2 @@
+DIST iwatch-0.2.2.tgz 16819 RMD160 a6d8c2ef053ac611699edff2e38d7402a92db5f3 SHA1 a9bce69a56cc9ed772c9d338238613a502671729 SHA256 beb2b8326b90130b3102cba38e6efb1f73622e9b52ea1b1da6270e2365ee0fe7
+EBUILD iwatch-0.2.2.ebuild 850 RMD160 71f4ff7adae39c39ae34d4d15b68356b13a7dc00 SHA1 5ad3aaf3bf04d83027ab9944e15a521e16645b54 SHA256 282ec5e79f319d1cb0eaca454a40d0c7bf59951e082590bb011b4e9875344168
diff --git a/sys-fs/iwatch/iwatch-0.2.2.ebuild b/sys-fs/iwatch/iwatch-0.2.2.ebuild
new file mode 100644
index 0000000..b1fb0d3
--- /dev/null
+++ b/sys-fs/iwatch/iwatch-0.2.2.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI="2"
+
+
+DESCRIPTION="A realtime filesystem monitoring program."
+HOMEPAGE="http://sourceforge.net/projects/iwatch"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tgz"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+DEPEND=""
+RDEPEND="dev-lang/perl
+ dev-perl/Linux-Inotify2
+ dev-perl/Event
+ dev-perl/Mail-Sendmail
+ dev-perl/XML-Simple
+ dev-perl/XML-SimpleObject"
+
+S="${WORKDIR}/${PN}"
+
+src_prepare() {
+ sed -i \
+ -e "s|/etc|${ROOT}usr/share/iwatch|" \
+ iwatch.xml{,.example} || die "sed failed"
+}
+
+src_install() {
+ dobin iwatch
+ dodoc AUTHORS ChangeLog README iwatch.xml iwatch.xml.example
+
+ insinto /usr/share/iwatch
+ doins iwatch.dtd
+}
+
+pkg_postinst() {
+ elog "Example configuration files are in ${ROOT}usr/share/doc/${PF}"
+}