summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-util/radare2/radare2-0.9.7.ebuild')
-rw-r--r--dev-util/radare2/radare2-0.9.7.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/dev-util/radare2/radare2-0.9.7.ebuild b/dev-util/radare2/radare2-0.9.7.ebuild
new file mode 100644
index 0000000..5e6da17
--- /dev/null
+++ b/dev-util/radare2/radare2-0.9.7.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI=5
+inherit base eutils
+
+DESCRIPTION="Advanced command line hexadecimal editor and more"
+HOMEPAGE="http://www.radare.org"
+SRC_URI="http://www.radare.org/get/radare2-${PV}.tar.xz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86 ~amd64"
+#IUSE="cparse debugger ewf gmp ssl sysmagic zlib"
+IUSE="cparse debugger ewf ssl"
+
+RDEPEND="ewf? ( app-forensics/libewf )
+ ssl? ( dev-libs/openssl )
+ "
+#gmp? ( dev-libs/gmp )
+#sysmagic? ( sys-libs/libmagic )
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+src_configure() {
+ econf $(use ssl && echo --with-openssl) \
+ $(use ewf || echo --without-ewf) \
+ $(use cparse && echo --enable-cparse) \
+ $(use debugger || echo --disable-debugger )
+}
+
+src_install() {
+ emake DESTDIR="${D}" INSTALL_PROGRAM="install" install || die "install failed"
+}