summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-vcs/perforce-cli/perforce-cli-2010.1.251161.ebuild')
-rw-r--r--dev-vcs/perforce-cli/perforce-cli-2010.1.251161.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/dev-vcs/perforce-cli/perforce-cli-2010.1.251161.ebuild b/dev-vcs/perforce-cli/perforce-cli-2010.1.251161.ebuild
new file mode 100644
index 0000000..a4fe959
--- /dev/null
+++ b/dev-vcs/perforce-cli/perforce-cli-2010.1.251161.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header$
+
+inherit versionator
+
+EAPI=2
+
+REL=$(get_version_component_range 1-2)
+SHORTREL=${REL/#20/}
+
+DESCRIPTION="Command line tool for Perforce version control system"
+HOMEPAGE="http://www.perforce.com/"
+SRC_URI="x86? ( ftp://ftp.perforce.com/perforce/r${SHORTREL}/bin.linux26x86/p4 \
+ -> ${PF}-x86 )
+ amd64? ( ftp://ftp.perforce.com/perforce/r${SHORTREL}/bin.linux26x86_64/p4 \
+ -> ${PF}-amd64 )"
+
+LICENSE="perforce"
+SLOT="0"
+KEYWORDS="-* ~x86 ~amd64"
+IUSE=""
+RESTRICT="mirror strip"
+
+S=${WORKDIR}
+
+src_unpack() {
+ # we have to copy all of the files from $DISTDIR, otherwise we get
+ # sandbox violations when trying to install
+
+ cp ${DISTDIR}/${A} p4
+}
+
+src_install() {
+ dobin p4 || die
+}