summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'guide/basic.html')
-rw-r--r--guide/basic.html30
1 files changed, 15 insertions, 15 deletions
diff --git a/guide/basic.html b/guide/basic.html
index a89c885..d9e698c 100644
--- a/guide/basic.html
+++ b/guide/basic.html
@@ -1,16 +1,16 @@
<!DOCTYPE html>
-<html lang="en">
+<html lang="en" data-content_root="./">
<head>
<meta charset="utf-8" />
<meta name="viewport" content="width=device-width, initial-scale=1.0" /><meta name="viewport" content="width=device-width, initial-scale=1" />
<title>Common basics &#8212; Gentoo Python Guide documentation</title>
- <link rel="stylesheet" type="text/css" href="_static/pygments.css?v=b3523f8e" />
+ <link rel="stylesheet" type="text/css" href="_static/pygments.css?v=4f649999" />
<link rel="stylesheet" type="text/css" href="_static/alabaster.css?v=039e1c02" />
- <script data-url_root="./" id="documentation_options" src="_static/documentation_options.js?v=b3ba4146"></script>
+ <script src="_static/documentation_options.js?v=5929fcd5"></script>
<script src="_static/doctools.js?v=888ff710"></script>
- <script src="_static/sphinx_highlight.js?v=4825356b"></script>
+ <script src="_static/sphinx_highlight.js?v=dc90522c"></script>
<link rel="index" title="Index" href="genindex.html" />
<link rel="search" title="Search" href="search.html" />
<link rel="next" title="python-any-r1 — build-time dependency" href="any.html" />
@@ -32,13 +32,13 @@
<div class="body" role="main">
<section id="common-basics">
-<h1>Common basics<a class="headerlink" href="#common-basics" title="Permalink to this heading">¶</a></h1>
+<h1>Common basics<a class="headerlink" href="#common-basics" title="Link to this heading">¶</a></h1>
<p>The various eclasses in python-r1 try to follow a single design. You
will probably use more than one of them, so it is worthwhile to shortly
explain the common bits used by all of them, as well as the non-obvious
differences between them.</p>
<section id="python-compat">
-<span id="index-0"></span><h2>PYTHON_COMPAT<a class="headerlink" href="#python-compat" title="Permalink to this heading">¶</a></h2>
+<span id="index-0"></span><h2>PYTHON_COMPAT<a class="headerlink" href="#python-compat" title="Link to this heading">¶</a></h2>
<p>The <code class="docutils literal notranslate"><span class="pre">PYTHON_COMPAT</span></code> variable is used by all Python eclasses, and must
be declared in all ebuilds before they are inherited. It specifies
the list of Python implementations supported by the package.</p>
@@ -52,9 +52,9 @@ the list of Python implementations supported by the package.</p>
inherit<span class="w"> </span>python-single-r1
</pre></div>
</div>
-<span class="target" id="index-1"></span></section>
+</section>
<section id="python-deps-and-python-required-use">
-<span id="index-2"></span><h2>PYTHON_DEPS and PYTHON_REQUIRED_USE<a class="headerlink" href="#python-deps-and-python-required-use" title="Permalink to this heading">¶</a></h2>
+<span id="index-2"></span><span id="index-1"></span><h2>PYTHON_DEPS and PYTHON_REQUIRED_USE<a class="headerlink" href="#python-deps-and-python-required-use" title="Link to this heading">¶</a></h2>
<p>The <code class="docutils literal notranslate"><span class="pre">python-any-r1</span></code>, <code class="docutils literal notranslate"><span class="pre">python-single-r1</span></code> and <code class="docutils literal notranslate"><span class="pre">python-r1</span></code> eclasses
all assume that the developer is responsible for explicitly putting
the dependency strings and USE requirements in correct variables.
@@ -74,9 +74,9 @@ Python unconditionally is to define the following:</p>
</div>
<p>This does not apply to <code class="docutils literal notranslate"><span class="pre">distutils-r1</span></code> as it does the above assignment
by default.</p>
-<span class="target" id="index-3"></span></section>
+</section>
<section id="python-environment">
-<span id="index-4"></span><h2>Python environment<a class="headerlink" href="#python-environment" title="Permalink to this heading">¶</a></h2>
+<span id="index-4"></span><span id="index-3"></span><h2>Python environment<a class="headerlink" href="#python-environment" title="Link to this heading">¶</a></h2>
<p>The eclasses commonly use the concept of <em>Python environment</em>. This
means a state of environment enforcing a particular Python
implementation. Whenever the ebuild code is run inside this
@@ -110,7 +110,7 @@ via calling <code class="docutils literal notranslate"><span class="pre">python_
<code class="docutils literal notranslate"><span class="pre">pkg_setup</span></code> in <code class="docutils literal notranslate"><span class="pre">python-any-r1</span></code> and <code class="docutils literal notranslate"><span class="pre">python-single-r1</span></code>.</p>
</section>
<section id="dependencies-in-python-packages">
-<h2>Dependencies in Python packages<a class="headerlink" href="#dependencies-in-python-packages" title="Permalink to this heading">¶</a></h2>
+<h2>Dependencies in Python packages<a class="headerlink" href="#dependencies-in-python-packages" title="Link to this heading">¶</a></h2>
<div class="admonition note">
<p class="admonition-title">Note</p>
<p>The following sections focus specifically on dependencies that
@@ -118,8 +118,8 @@ are Python packages. Python software often depends on external
tools, libraries written in other programming languages, etc.
For these dependencies, the usual Gentoo rules apply.</p>
</div>
-<span class="target" id="index-5"></span><span class="target" id="index-6"></span><section id="the-most-common-dependency-types">
-<span id="index-7"></span><h3>The most common dependency types<a class="headerlink" href="#the-most-common-dependency-types" title="Permalink to this heading">¶</a></h3>
+<section id="the-most-common-dependency-types">
+<span id="index-7"></span><span id="index-6"></span><span id="index-5"></span><h3>The most common dependency types<a class="headerlink" href="#the-most-common-dependency-types" title="Link to this heading">¶</a></h3>
<p>The dependencies found in Python packages can usually be classified
into two categories: runtime dependencies and build-time dependencies.</p>
<p><em>Runtime dependencies</em> are packages that are required to be present
@@ -186,7 +186,7 @@ in all three of <code class="docutils literal notranslate"><span class="pre">RDE
or for tests).</p>
</section>
<section id="finding-dependency-lists-from-build-systems">
-<h3>Finding dependency lists from build systems<a class="headerlink" href="#finding-dependency-lists-from-build-systems" title="Permalink to this heading">¶</a></h3>
+<h3>Finding dependency lists from build systems<a class="headerlink" href="#finding-dependency-lists-from-build-systems" title="Link to this heading">¶</a></h3>
<p>Most of the modern Python build systems include all the package metadata
in the <code class="docutils literal notranslate"><span class="pre">pyproject.toml</span></code> file. Setuptools are using <code class="docutils literal notranslate"><span class="pre">setup.cfg</span></code>
and/or <code class="docutils literal notranslate"><span class="pre">setup.py</span></code>. Some packages also include custom code to read
@@ -338,7 +338,7 @@ or <code class="docutils literal notranslate"><span class="pre">noxfile.py</span
&copy;2020, Michał Górny, license: CC BY 4.0.
|
- Powered by <a href="http://sphinx-doc.org/">Sphinx 7.1.2</a>
+ Powered by <a href="http://sphinx-doc.org/">Sphinx 7.2.6</a>
&amp; <a href="https://github.com/bitprophet/alabaster">Alabaster 0.7.13</a>
|