summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPhilip Miess <Philip_Miess@yahoo.com>2023-03-26 14:40:09 -0400
committerPhilip Miess <Philip_Miess@yahoo.com>2023-03-26 14:40:09 -0400
commit476f7f0cf75e7008a45a2961c4c1032f76a7af66 (patch)
treefbe57a6115f05937c32017d355f8c291d974ac92
parentresurrect jutils (diff)
downloadsuperposition-476f7f0cf75e7008a45a2961c4c1032f76a7af66.tar.gz
superposition-476f7f0cf75e7008a45a2961c4c1032f76a7af66.tar.bz2
superposition-476f7f0cf75e7008a45a2961c4c1032f76a7af66.zip
resurrect asm 5.1
Signed-off-by: Philip Miess <Philip_Miess@yahoo.com>
-rw-r--r--dev-java/asm/Manifest3
-rw-r--r--dev-java/asm/asm-5.1-r1.ebuild48
2 files changed, 51 insertions, 0 deletions
diff --git a/dev-java/asm/Manifest b/dev-java/asm/Manifest
index 69315c8..3052d6a 100644
--- a/dev-java/asm/Manifest
+++ b/dev-java/asm/Manifest
@@ -1,3 +1,6 @@
+DIST asm-ASM_4_0.tar.gz 14789505 BLAKE2B 62b49d904f1ef2d32379f4f5d644cdc274b30f292ee4f64ad02be7d2226a90965f7b12421700e79dcd1e67a46e6a8543d5e353486a1577313616688ddc57f3b3 SHA512 e654623a882d9fe414e71861183f64840f7b6629231864872497d4bf9274e8ac05e05496593fa54a90d8c6a2e6d701b9a6f3876df611637f7d2079c5519def1e
+DIST asm-ASM_5_1.tar.gz 16258842 BLAKE2B bd7d717cdfa6ff652c96b88d7b7d33fae614acba390c256ea72ecfbb3edc48382621a076dedf9b8728fdb1d0961cda943f165f99de840824b766c9af45a49339 SHA512 4bb32ce6eba267928261238f8f13cd2365ab374780039ad1df31698cd791645a370aca58c44270ec05f8377d6aa0a0d00f9f3890961cbd32a10cbd2e79e2d518
DIST asm-ASM_9_4.tar.bz2 1380417 BLAKE2B 612fc6669294f2926ec77522f642f2878a96a9c977579ceda9feb955041ff53fa698c75b26c27bae478a41dca59357d9cf824263df39d60ea5c6722e5f0efc75 SHA512 a59268808ac54a238bd6e117eb0164d28c5c3572c12d7ad42c2f3dbd32714c03056f330255756511db4f1ede8d66bf32c7347128b8ec179beba11cca27927687
+EBUILD asm-5.1-r1.ebuild 1280 BLAKE2B 9b4395b97760514e0f54c72ab1df3a0751991d13caf567a0441fb16c05f4a89559b1347b19a820ea79871123895a4f86431230fd41bd4735aa1e0d4e57c7d128 SHA512 78fa99694b9a1156a85067bab400bfb99f83f4908cd0e6f03eb64e067b15fe757f3cf4cd6b8b109227d6c42b1e3bc2900fc798d3e35d7323cf18a6dde9605c69
EBUILD asm-9.4.ebuild 2363 BLAKE2B 36b4ba331468998e388a6d240c99d0c195cee271c135f8180cdaebdce6546a6837c4a1533333889aee4dec0352dbc883de936d86bea6c80477e616c01cdd3b57 SHA512 2ead6c41436c36bc9011963a74d2fac092ffc22e31ca9cf7f5d5fcbfe05754223d3ca88f2bea77b4c72c3ef610978a23b525513e16b1d6e151a4590aad6889b4
MISC metadata.xml 1233 BLAKE2B 13faf251d3d40ed558c83262972ea106892cc3be0f7a1b95a0b484123d93473bd867b2f7b53c3e5ccc2f1fe249ebe66cb9e757e19ad36c8d3e3eac6a7a981d98 SHA512 59a292291ac757818e41d009e2cdbb73b6d914c1f552c34e9360635cb468f1ebfdf9c58d6642710d5218689d08797320102c8ccb6d5f4bc9478883feb9b9b397
diff --git a/dev-java/asm/asm-5.1-r1.ebuild b/dev-java/asm/asm-5.1-r1.ebuild
new file mode 100644
index 0000000..ff2f2f9
--- /dev/null
+++ b/dev-java/asm/asm-5.1-r1.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+JAVA_PKG_IUSE="doc source"
+
+inherit java-pkg-2 java-ant-2
+
+DESCRIPTION="Bytecode manipulation framework for Java"
+HOMEPAGE="https://asm.ow2.io"
+MY_P="ASM_${PV//./_}"
+SRC_URI="https://gitlab.ow2.org/asm/asm/-/archive/${MY_P}/asm-${MY_P}.tar.gz https://gitlab.ow2.org/asm/asm/-/archive/ASM_4_0/asm-ASM_4_0.tar.gz"
+
+LICENSE="BSD"
+SLOT="4"
+KEYWORDS="amd64 ~arm arm64 ppc64 x86 ~x64-macos"
+
+CDEPEND=""
+DEPEND=">=virtual/jdk-1.8:*"
+RDEPEND=">=virtual/jre-1.8:*"
+
+S="${WORKDIR}/asm-${MY_P}"
+
+# Needs dependencies we don't have yet.
+RESTRICT="test"
+
+EANT_DOC_TARGET="jdoc"
+
+# Fails if this objectweb.ant.tasks.path is not set.
+# Java generics seem to break unless product.noshrink is set.
+EANT_EXTRA_ARGS="-Dobjectweb.ant.tasks.path=foobar -Dproduct.noshrink=true"
+
+src_prepare() {
+ default
+ # Borrow some ant scripts from an old version to avoid requiring
+ # bndlib and friends. This may not work forever!
+ cp -vf "../asm-ASM_4_0/archive"/*.xml archive/ || die
+}
+
+src_install() {
+ for x in output/dist/lib/*.jar ; do
+ java-pkg_newjar "${x}" $(basename "${x%-*}.jar")
+ done
+
+ use doc && java-pkg_dojavadoc output/dist/doc/javadoc/user/
+ use source && java-pkg_dosrc src/*
+}