summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJohn M. Harris Jr. <johnmh@johnmh.me>2024-07-01 16:17:27 -0700
committerJohn M. Harris Jr. <johnmh@johnmh.me>2024-07-01 16:17:27 -0700
commit5c400aa384b867603149739b0a4d540d05c0b1ab (patch)
tree8319f4b1aa073a8be1bb6500963ed1096cc31deb
parentdev-util/hyprwayland-scanner: treeclean (diff)
downloadjohnmh-5c400aa384b867603149739b0a4d540d05c0b1ab.tar.gz
johnmh-5c400aa384b867603149739b0a4d540d05c0b1ab.tar.bz2
johnmh-5c400aa384b867603149739b0a4d540d05c0b1ab.zip
gui-libs/xdg-desktop-portal-hyprland: treeclean
Signed-off-by: John M. Harris Jr. <johnmh@johnmh.me>
-rw-r--r--gui-libs/xdg-desktop-portal-hyprland/Manifest1
-rw-r--r--gui-libs/xdg-desktop-portal-hyprland/xdg-desktop-portal-hyprland-9999.ebuild88
2 files changed, 0 insertions, 89 deletions
diff --git a/gui-libs/xdg-desktop-portal-hyprland/Manifest b/gui-libs/xdg-desktop-portal-hyprland/Manifest
deleted file mode 100644
index 0386988..0000000
--- a/gui-libs/xdg-desktop-portal-hyprland/Manifest
+++ /dev/null
@@ -1 +0,0 @@
-EBUILD xdg-desktop-portal-hyprland-9999.ebuild 2202 BLAKE2B 193519fddbef4fe5204d980320c1c65a55dd9ca7626a35afc46b5c7883c08bb14d8bb054f7ea88a6b50169e610a291005b98563f731da2ea403af5003cec7c01 SHA512 d37663671b7b3bb1a6c1ce55d246a5d97150c732431174ef3e0e443788ac038663106c66d21c1a904da3f1ffab15088cebbd0b450f7aa4d570d4d11e4c4a3d18
diff --git a/gui-libs/xdg-desktop-portal-hyprland/xdg-desktop-portal-hyprland-9999.ebuild b/gui-libs/xdg-desktop-portal-hyprland/xdg-desktop-portal-hyprland-9999.ebuild
deleted file mode 100644
index cac4dad..0000000
--- a/gui-libs/xdg-desktop-portal-hyprland/xdg-desktop-portal-hyprland-9999.ebuild
+++ /dev/null
@@ -1,88 +0,0 @@
-# Copyright 2022-2024 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-inherit cmake toolchain-funcs
-
-DESCRIPTION="xdg-desktop-portal backend for hyprland"
-HOMEPAGE="https://github.com/hyprwm/xdg-desktop-portal-hyprland"
-
-if [[ ${PV} == 9999 ]]; then
- EGIT_REPO_URI="https://github.com/hyprwm/xdg-desktop-portal-hyprland.git"
- inherit git-r3
-else
- PROTO_COMMIT="4d29e48433270a2af06b8bc711ca1fe5109746cd"
- SRC_URI="https://github.com/hyprwm/xdg-desktop-portal-hyprland/archive/refs/tags/v${PV}.tar.gz \
- -> xdg-desktop-hyprland-${PV}.tar.gz
- https://github.com/hyprwm/hyprland-protocols/archive/${PROTO_COMMIT}.tar.gz \
- -> proto-subproject-${PV}.tar.gz"
- KEYWORDS="~amd64"
-fi
-
-LICENSE="MIT"
-SLOT="0"
-IUSE="elogind systemd"
-REQUIRED_USE="?? ( elogind systemd )"
-
-DEPEND="
- >=media-video/pipewire-0.3.41:=
- dev-cpp/sdbus-c++
- dev-libs/hyprlang:=
- dev-libs/inih
- dev-libs/wayland
- dev-qt/qtbase
- dev-qt/qtcore
- dev-qt/qtgui
- dev-qt/qtwayland:6
- dev-qt/qtwidgets
- media-libs/mesa
- sys-apps/util-linux
- x11-libs/libdrm
- || (
- systemd? ( >=sys-apps/systemd-237 )
- elogind? ( >=sys-auth/elogind-237 )
- sys-libs/basu
- )
-"
-
-RDEPEND="
- ${DEPEND}
- sys-apps/xdg-desktop-portal
-"
-
-BDEPEND="
- >=dev-libs/wayland-protocols-1.24
- dev-libs/hyprland-protocols
- virtual/pkgconfig
- || ( >=sys-devel/gcc-13:* >=sys-devel/clang-17:* )
-"
-
-pkg_setup() {
- [[ ${MERGE_TYPE} == binary ]] && return
-
- if tc-is-gcc && ver_test $(gcc-version) -lt 13 ; then
- eerror "XDPH needs >=gcc-13 or >=clang-17 to compile."
- eerror "Please upgrade GCC: emerge -v1 sys-devel/gcc"
- die "GCC version is too old to compile XDPH!"
- elif tc-is-clang && ver_test $(clang-version) -lt 17 ; then
- eerror "XDPH needs >=gcc-13 or >=clang-17 to compile."
- eerror "Please upgrade Clang: emerge -v1 sys-devel/clang"
- die "Clang version is too old to compile XDPH!"
- fi
-}
-
-src_unpack() {
- if [[ ${PV} == 9999 ]]; then
- git-r3_src_unpack
- else
- default
- rmdir "${S}/subprojects/hyprland-protocols" || die
- mv "hyprland-protocols-${PROTO_COMMIT}" "${S}/subprojects/hyprland-protocols" || die
- fi
-}
-
-src_prepare() {
- sed -i "/add_compile_options(-O3)/d" "${S}/CMakeLists.txt" || die
- cmake_src_prepare
-}