summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJohn M. Harris Jr. <johnmh@johnmh.me>2024-07-27 10:55:03 -0700
committerJohn M. Harris Jr. <johnmh@johnmh.me>2024-07-27 10:55:03 -0700
commit04a38668eaa40a3e93c7eb1c862aa4e043d6b8e1 (patch)
treefccf3206198019e2fefd4d544626c0530f38859d
parentmedia-sound/strawberry: new package, add 9999 (diff)
downloadjohnmh-04a38668eaa40a3e93c7eb1c862aa4e043d6b8e1.tar.gz
johnmh-04a38668eaa40a3e93c7eb1c862aa4e043d6b8e1.tar.bz2
johnmh-04a38668eaa40a3e93c7eb1c862aa4e043d6b8e1.zip
gui-libs/aquamarine: new package, add 9999
Signed-off-by: John M. Harris Jr. <johnmh@johnmh.me>
-rw-r--r--gui-libs/aquamarine/Manifest2
-rw-r--r--gui-libs/aquamarine/aquamarine-9999.ebuild51
-rw-r--r--gui-libs/aquamarine/metadata.xml21
3 files changed, 74 insertions, 0 deletions
diff --git a/gui-libs/aquamarine/Manifest b/gui-libs/aquamarine/Manifest
new file mode 100644
index 0000000..836d920
--- /dev/null
+++ b/gui-libs/aquamarine/Manifest
@@ -0,0 +1,2 @@
+EBUILD aquamarine-9999.ebuild 1032 BLAKE2B 5cc85135866b7a6b55d7c4fdfba17abb1ec556292b4a95d0b94edef50c33e69b13b3e5bc9f0ca9725954c9a8a4acb90a3af6b9ab77b8ef3224320ddf719a8144 SHA512 0ef3f42c5e582ca1117542f17f4d88167b2de2ce77828009fb73df52bc31dda3d7639798fc63ee3026f4c7195890855d13592d5d85b7045a30edcdfa6132785a
+MISC metadata.xml 758 BLAKE2B a65a9e66b86adfb07863ac5478017cbb2600947533120b7df4e88b5d15ba2993d05dd1283043c7db0663bd9a48945c65bec2ffa51c78d25c6d1ce68bd9fab9c9 SHA512 99db8f2458d4004ad61bdeac7dbdad89274dbcd935d6609cfcffbc7af975212dd8eb5126d04cb0a6f2f05129eb7df7df67cb38aa207271da61aea66afbad36f8
diff --git a/gui-libs/aquamarine/aquamarine-9999.ebuild b/gui-libs/aquamarine/aquamarine-9999.ebuild
new file mode 100644
index 0000000..ae50cc1
--- /dev/null
+++ b/gui-libs/aquamarine/aquamarine-9999.ebuild
@@ -0,0 +1,51 @@
+# Copyright 2023-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake
+
+DESCRIPTION="Aquamarine is a very light linux rendering backend library"
+HOMEPAGE="https://github.com/hyprwm/aquamarine"
+
+if [[ "${PV}" = *9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/hyprwm/${PN^}.git"
+else
+ SRC_URI="https://github.com/hyprwm/${PN^}/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64"
+fi
+
+LICENSE="BSD"
+SLOT="0"
+
+RDEPEND="
+ dev-libs/wayland
+ media-libs/mesa[opengl]
+ media-libs/libdisplay-info
+ >=dev-libs/libinput-1.26.1
+ >=dev-util/hyprwayland-scanner-0.4.0
+ >=gui-libs/hyprutils-0.1.5
+ x11-libs/cairo
+ x11-libs/libxkbcommon
+ x11-libs/libdrm
+ x11-libs/pango
+ x11-libs/pixman
+ virtual/libudev
+ sys-apps/hwdata
+ >=sys-auth/seatd-0.8.0
+"
+DEPEND="
+ ${RDEPEND}
+ dev-libs/wayland-protocols
+"
+
+BDEPEND="
+ dev-util/wayland-scanner
+ virtual/pkgconfig
+"
+
+src_prepare() {
+ sed -i "/add_compile_options(-O3)/d" "${S}/CMakeLists.txt" || die
+ cmake_src_prepare
+}
diff --git a/gui-libs/aquamarine/metadata.xml b/gui-libs/aquamarine/metadata.xml
new file mode 100644
index 0000000..3b4e390
--- /dev/null
+++ b/gui-libs/aquamarine/metadata.xml
@@ -0,0 +1,21 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person" proxied="yes">
+ <email>julien@jroy.ca</email>
+ <name>Julien Roy</name>
+ </maintainer>
+ <maintainer type="person" proxied="yes">
+ <email>johnmh@johnmh.me</email>
+ <name>John M. Harris, Jr.</name>
+ </maintainer>
+ <maintainer type="project" proxied="proxy">
+ <email>proxy-maint@gentoo.org</email>
+ <name>Proxy Maintainers</name>
+ </maintainer>
+ <upstream>
+ <changelog>https://github.com/hyprwm/aquamarine/releases</changelog>
+ <bugs-to>https://github.com/hyprwm/aquamarine/issues</bugs-to>
+ <remote-id type="github">hyprwm/aquamarine</remote-id>
+ </upstream>
+</pkgmetadata>