summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSimon the Sorcerer <neuron@mail.uni-paderborn.de>2017-12-23 08:16:06 +0100
committerSimon the Sorcerer <neuron@mail.uni-paderborn.de>2017-12-23 08:16:06 +0100
commitc465e5bab2e181677a44fedf2184b6a9eeaaf555 (patch)
tree8a4ef93d50a40b5f68f0a723200842a3e5427c93
parentadded app-misc/oneko x11-plugins/lurch sys-apps/spi-tools. (diff)
downloaddarkelf-c465e5bab2e181677a44fedf2184b6a9eeaaf555.tar.gz
darkelf-c465e5bab2e181677a44fedf2184b6a9eeaaf555.tar.bz2
darkelf-c465e5bab2e181677a44fedf2184b6a9eeaaf555.zip
added media-sound/exaile.
-rw-r--r--media-sound/exaile/Manifest2
-rw-r--r--media-sound/exaile/exaile-9999.ebuild84
-rw-r--r--media-sound/exaile/metadata.xml13
3 files changed, 99 insertions, 0 deletions
diff --git a/media-sound/exaile/Manifest b/media-sound/exaile/Manifest
new file mode 100644
index 0000000..767da51
--- /dev/null
+++ b/media-sound/exaile/Manifest
@@ -0,0 +1,2 @@
+EBUILD exaile-9999.ebuild 1892 SHA256 c70a8c4dd22593d532a7a8e02dcf62a4d2a1fb64a3facef0585ece8f63397203 SHA512 bc72dab867ad528d35c20d47535c1de4e03f7c154facdb7d94ef35d38e378a1861adbebefe9d12e2dd209c44f0470181e837548b12f3d6766fcebccce5a740da WHIRLPOOL b1ef2a634c6931f20102a2d3159ae6ea1e714836fbcb56a50da4d2435a95a9c3d9ceb28d60a0190daf91df3466e57fb1af1c7acb6824762ee80166ff16c2c7be
+MISC metadata.xml 504 SHA256 f38e827adcc8292c57cdd9b887cbbb6689954039971671eb7f4d396914f74b06 SHA512 d5946d65a06878be9d4de4581b51373080bf174e661ba0de0e3bc8311a0008928796aa6cb9d6a958a58a1b89065b57520b78dbc2587e3bb6067f084e68c4964c WHIRLPOOL db194fff48ee6a36f78c8c479263014996833651ef3de6f529ecc33de4e7fff183490ee156a1e7a3e4c7dea7012d8c405a919c367b572840821186796cd1ffb8
diff --git a/media-sound/exaile/exaile-9999.ebuild b/media-sound/exaile/exaile-9999.ebuild
new file mode 100644
index 0000000..27c4425
--- /dev/null
+++ b/media-sound/exaile/exaile-9999.ebuild
@@ -0,0 +1,84 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 )
+PYTHON_REQ_USE="sqlite"
+
+inherit multilib python-single-r1 versionator xdg-utils
+
+if [[ ${PV} == "9999" ]] ; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/exaile/exaile.git"
+ MY_PV="${PV}"
+ KEYWORDS=""
+else
+ SRC_URI="https://github.com/${PN}/${PN}/archive/${MY_PV}.tar.gz -> ${P}.tar.gz"
+ MY_PV="$(replace_version_separator 3 '-')"
+ KEYWORDS="~amd64 ~x86 ~arm"
+fi
+
+DESCRIPTION="a media player aiming to be similar to AmaroK, but for GTK+"
+HOMEPAGE="http://www.exaile.org/"
+
+LICENSE="GPL-2 GPL-3"
+SLOT="0"
+IUSE="cddb libnotify moodbar nls scrobbler"
+
+RDEPEND="
+ ${PYTHON_DEPS}
+ dev-python/bsddb3[${PYTHON_USEDEP}]
+ dev-python/dbus-python[${PYTHON_USEDEP}]
+ dev-python/gst-python:1.0[${PYTHON_USEDEP}]
+ dev-python/pycairo[${PYTHON_USEDEP}]
+ >=x11-libs/gtk+-3.10:3[introspection]
+ >=dev-python/pygobject-3.13.2:3[${PYTHON_USEDEP}]
+ >=media-libs/gst-plugins-base-1.6:1.0
+ >=media-libs/gst-plugins-good-1.4:1.0
+ >=media-libs/mutagen-1.10[${PYTHON_USEDEP}]
+ media-plugins/gst-plugins-meta:1.0
+ cddb? ( dev-python/cddb-py )
+ scrobbler? ( dev-python/pylast[${PYTHON_USEDEP}] )
+ libnotify? ( dev-python/notify-python )
+ moodbar? ( media-sound/moodbar )"
+DEPEND="
+ nls? (
+ dev-util/intltool
+ sys-devel/gettext
+ )"
+
+RESTRICT="test" #315589
+
+S="${WORKDIR}/${PN}-${MY_PV}"
+
+pkg_setup() {
+ python-single-r1_pkg_setup
+}
+
+src_compile() {
+ if use nls; then
+ emake locale
+ fi
+}
+
+src_install() {
+ emake \
+ PREFIX=/usr \
+ LIBINSTALLDIR=/$(get_libdir) \
+ DESTDIR="${D}" \
+ install$(use nls || echo _no_locale)
+
+ python_optimize "${D}$(get_libdir)/${PN}"
+ python_optimize "${D}/usr/share/${PN}"
+}
+
+pkg_postinst() {
+ xdg_desktop_database_update
+ xdg_mimeinfo_database_update
+}
+
+pkg_postrm() {
+ xdg_desktop_database_update
+ xdg_mimeinfo_database_update
+}
diff --git a/media-sound/exaile/metadata.xml b/media-sound/exaile/metadata.xml
new file mode 100644
index 0000000..ec66a64
--- /dev/null
+++ b/media-sound/exaile/metadata.xml
@@ -0,0 +1,13 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<maintainer type="person">
+ <email>neuron@mail.uni-paderborn.de</email>
+ <description>Primary maintainer</description>
+</maintainer>
+<longdescription>A media player aiming to be similar to AmaroK, but for GTK+.</longdescription>
+<use>
+ <flag name="scrobbler">Enable audioscrobbler/last.fm support.</flag>
+ <flag name="moodbar">Enable moodbar support.</flag>
+</use>
+</pkgmetadata>