summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlbert Diserholt <albert@diserholt.com>2017-04-25 10:04:50 +0200
committerAlbert Diserholt <albert@diserholt.com>2017-04-25 10:04:50 +0200
commitf799d767efee0c143a048dadd650409d0183d6a3 (patch)
tree6579ba749f587acb2637e94c49980572d8c324fe /dev-lang
parentFixed Haxe build dependency. (diff)
downloadDrauthius-f799d767efee0c143a048dadd650409d0183d6a3.tar.gz
Drauthius-f799d767efee0c143a048dadd650409d0183d6a3.tar.bz2
Drauthius-f799d767efee0c143a048dadd650409d0183d6a3.zip
Updated haxe and aseprite
Thanks to Alexander Konotop for haxe ebuild and fixes.
Diffstat (limited to 'dev-lang')
-rw-r--r--dev-lang/haxe/Manifest1
-rw-r--r--dev-lang/haxe/haxe-3.4.2.ebuild36
2 files changed, 37 insertions, 0 deletions
diff --git a/dev-lang/haxe/Manifest b/dev-lang/haxe/Manifest
index 99549fc..6483521 100644
--- a/dev-lang/haxe/Manifest
+++ b/dev-lang/haxe/Manifest
@@ -1 +1,2 @@
EBUILD haxe-3.2.0.ebuild 710 SHA256 3caa872083803bed4b1c22cd0843c0a5031876a2728b59526a5155ba416a9491 SHA512 07a64770a5f7181d31bb44ab6f88afe52e1cdbb12fa0fa3d223c8b26b2b0e0f843fb9cacfb022bd53ee720a4576b162466fe5d4397c44d861f2327a09b7a4ad4 WHIRLPOOL 9f083c898500c2c76bebd2bbc458d87e3642c5e63cac641882b76e488b8428444fd39770d8921a70a14f4703e14a74b1db244d86f156f31eca0677c83a0d5288
+EBUILD haxe-3.4.2.ebuild 710 SHA256 3caa872083803bed4b1c22cd0843c0a5031876a2728b59526a5155ba416a9491 SHA512 07a64770a5f7181d31bb44ab6f88afe52e1cdbb12fa0fa3d223c8b26b2b0e0f843fb9cacfb022bd53ee720a4576b162466fe5d4397c44d861f2327a09b7a4ad4 WHIRLPOOL 9f083c898500c2c76bebd2bbc458d87e3642c5e63cac641882b76e488b8428444fd39770d8921a70a14f4703e14a74b1db244d86f156f31eca0677c83a0d5288
diff --git a/dev-lang/haxe/haxe-3.4.2.ebuild b/dev-lang/haxe/haxe-3.4.2.ebuild
new file mode 100644
index 0000000..3995786
--- /dev/null
+++ b/dev-lang/haxe/haxe-3.4.2.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+inherit git-r3
+
+EGIT_REPO_URI="https://github.com/HaxeFoundation/${PN}"
+EGIT_COMMIT=${PV}
+SRC_URI=""
+KEYWORDS="~amd64 ~x86"
+
+DESCRIPTION="Haxe cross-platform toolkit"
+HOMEPAGE="http://haxe.org/"
+
+LICENSE="GPL-2 LGPL-2.1 BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND=""
+DEPEND="${RDEPEND}
+ dev-lang/neko
+ >=dev-lang/ocaml-4.02[ocamlopt]
+ dev-libs/libpcre
+ dev-ml/camlp4[ocamlopt]
+ sys-libs/zlib"
+
+MAKEOPTS+=" -j1"
+
+src_install() {
+ mkdir -p "${D}/usr/bin" # Missing from install target
+ emake INSTALL_DIR="${D}/usr" install
+ # Strip destination from haxelib.
+ sed -i "s|${D}||" "${D}/usr/bin/haxelib"
+}