summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'www-apps/cvsweb/cvsweb-1.112.ebuild')
-rw-r--r--www-apps/cvsweb/cvsweb-1.112.ebuild37
1 files changed, 37 insertions, 0 deletions
diff --git a/www-apps/cvsweb/cvsweb-1.112.ebuild b/www-apps/cvsweb/cvsweb-1.112.ebuild
new file mode 100644
index 000000000000..bbe5cb1d285e
--- /dev/null
+++ b/www-apps/cvsweb/cvsweb-1.112.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+DESCRIPTION="WWW interface to a CVS tree"
+HOMEPAGE="http://www.freebsd.org/projects/cvsweb.html"
+SRC_URI="mirror://gentoo/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="x86 sparc ~ppc"
+IUSE=""
+
+RDEPEND=">=dev-lang/perl-5
+ >=dev-vcs/rcs-5.7"
+
+S="${WORKDIR}/cvsweb"
+
+src_unpack() {
+ unpack ${P}.tar.gz
+ cd "${S}"
+ local x
+ for x in cvsweb.cgi cvsweb.conf
+ do
+ cp ${x} ${x}.orig
+ sed -e "s:/usr/local/web/apache/conf/:/etc/apache/conf/:g" ${x}.orig > ${x}
+ done
+}
+
+src_install() {
+ insinto /etc/apache/conf
+ doins cvsweb.conf
+ insinto /home/httpd/cgi-bin
+ insopts -m755
+ doins cvsweb.cgi
+ dodoc README TODO
+}