summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-fs/encfs/encfs-1.8.1-r1.ebuild')
-rw-r--r--sys-fs/encfs/encfs-1.8.1-r1.ebuild50
1 files changed, 0 insertions, 50 deletions
diff --git a/sys-fs/encfs/encfs-1.8.1-r1.ebuild b/sys-fs/encfs/encfs-1.8.1-r1.ebuild
deleted file mode 100644
index 4c78b1b63771..000000000000
--- a/sys-fs/encfs/encfs-1.8.1-r1.ebuild
+++ /dev/null
@@ -1,50 +0,0 @@
-# Copyright 1999-2016 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI="5"
-inherit autotools eutils multilib
-
-DESCRIPTION="An implementation of encrypted filesystem in user-space using FUSE"
-HOMEPAGE="https://vgough.github.io/encfs/"
-SRC_URI="https://github.com/vgough/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="GPL-3"
-SLOT="0"
-KEYWORDS="~amd64 ~arm ~sparc ~x86"
-IUSE="xattr nls libressl"
-
-RDEPEND="dev-libs/boost:=
- !libressl? ( dev-libs/openssl:0= )
- libressl? ( dev-libs/libressl:0= )
- dev-libs/rlog
- sys-fs/fuse
- sys-libs/zlib"
-# Your libc probably provides xattrs, but to be safe
-# we'll dep on sys-apps/attr. This should be fixed
-# if we ever create a virtual/attr.
-DEPEND="${RDEPEND}
- dev-lang/perl
- virtual/pkgconfig
- xattr? ( sys-apps/attr )
- nls? ( sys-devel/gettext )"
-
-src_prepare() {
- eautoreconf
-}
-
-src_configure() {
- # configure searches for either attr/xattr.h or sys/xattr.h
- use xattr || export ac_cv_header_{attr,sys}_xattr_h=no
-
- econf \
- $(use_enable nls) \
- --disable-valgrind \
- --enable-openssl \
- --disable-dependency-tracking
-}
-
-src_install() {
- emake DESTDIR="${D}" install || die
- dodoc AUTHORS ChangeLog README.md
- find "${D}" -name '*.la' -delete
-}