summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-apps/gentoo-functions/gentoo-functions-0.9.ebuild')
-rw-r--r--sys-apps/gentoo-functions/gentoo-functions-0.9.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/sys-apps/gentoo-functions/gentoo-functions-0.9.ebuild b/sys-apps/gentoo-functions/gentoo-functions-0.9.ebuild
new file mode 100644
index 000000000000..f877ef4acdcd
--- /dev/null
+++ b/sys-apps/gentoo-functions/gentoo-functions-0.9.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+if [[ ${PV} = 9999* ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="git://github.com/gentoo/${PN}.git"
+else
+ SRC_URI="https://github.com/gentoo/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~ppc-aix ~amd64-fbsd ~sparc-fbsd ~x86-fbsd ~x64-freebsd ~x86-freebsd ~hppa-hpux ~ia64-hpux ~x86-interix ~amd64-linux ~arm-linux ~ia64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~m68k-mint ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris ~x86-winnt"
+fi
+
+inherit toolchain-funcs
+
+DESCRIPTION="base functions required by all gentoo systems"
+HOMEPAGE="http://www.gentoo.org"
+
+LICENSE="GPL-2"
+SLOT="0"
+IUSE=""
+
+src_prepare() {
+ tc-export CC
+}
+
+src_install() {
+ emake install DESTDIR="${ED}"
+}