summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sci-libs/tnt/tnt-1.2.6.ebuild')
-rw-r--r--sci-libs/tnt/tnt-1.2.6.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/sci-libs/tnt/tnt-1.2.6.ebuild b/sci-libs/tnt/tnt-1.2.6.ebuild
new file mode 100644
index 000000000000..ee0bb59337cf
--- /dev/null
+++ b/sci-libs/tnt/tnt-1.2.6.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+
+inherit versionator
+
+MYP="${PN}$(replace_all_version_separators '')"
+DOCPV=120
+
+DESCRIPTION="Template Numerical Toolkit: C++ headers for array and matrices"
+HOMEPAGE="http://math.nist.gov/tnt/"
+SRC_URI="http://math.nist.gov/tnt/${MYP}.zip
+ doc? ( http://math.nist.gov/tnt/${PN}${DOCPV}doc.zip )"
+
+LICENSE="public-domain"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+
+IUSE="doc"
+
+DEPEND="app-arch/unzip"
+RDEPEND=""
+
+S="${WORKDIR}"
+
+src_install() {
+ insinto /usr/include
+ doins *.h
+ use doc && dohtml html/*
+}