summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sci-libs/starparse')
-rw-r--r--sci-libs/starparse/Manifest1
-rw-r--r--sci-libs/starparse/files/starparse-1.0-guile1.8.patch60
-rw-r--r--sci-libs/starparse/metadata.xml5
-rw-r--r--sci-libs/starparse/starparse-1.0-r1.ebuild33
4 files changed, 99 insertions, 0 deletions
diff --git a/sci-libs/starparse/Manifest b/sci-libs/starparse/Manifest
new file mode 100644
index 000000000000..96c1a511585f
--- /dev/null
+++ b/sci-libs/starparse/Manifest
@@ -0,0 +1 @@
+DIST starparse-1.0.tar.bz2 5466370 SHA256 0ff25bb00c9481136bd060660340a44095902e17d75cc11d749ace597b5f4c61 SHA512 47e862258281a3faa506d4eb573a2819a9f5b1cb16828c4951d5d23bbfa8877d9b737ca0b33136dcf8ae0e96ecc9d310ba65a5b7cf1fe18ab8beb092f2342e9a WHIRLPOOL 6bb9a9c5b60888045d64b8890c278c97f80b4abb95678f6db166d23c744ac106f0db3913f77e4bda958c8edf8a51f0f7bcd6a93790fe2691081ec231b2ff11cb
diff --git a/sci-libs/starparse/files/starparse-1.0-guile1.8.patch b/sci-libs/starparse/files/starparse-1.0-guile1.8.patch
new file mode 100644
index 000000000000..1d6e176b079e
--- /dev/null
+++ b/sci-libs/starparse/files/starparse-1.0-guile1.8.patch
@@ -0,0 +1,60 @@
+--- src/guile-binding.c
++++ src/guile-binding.c
+@@ -61,10 +61,10 @@
+ char* filter_string = NULL;
+ char* fname = "-";
+
+- if (SCM_NFALSEP(filter_string_scm))
++ if (scm_is_true(filter_string_scm))
+ filter_string = scm_to_locale_string(filter_string_scm);
+
+- if (SCM_NFALSEP(fname_scm))
++ if (scm_is_true(fname_scm))
+ fname = scm_to_locale_string(fname_scm);
+
+ ship_item_cb = ship_item_scm;
+--- src/Makefile.am
++++ src/Makefile.am
+@@ -6,13 +6,10 @@
+ libstarparse_la_SOURCES =\
+ parser.y lexer.l starparse.h
+
+-libstarparse_la_CFLAGS =
+-libstarparse_la_LDFLAGS =
+-
+ if ENABLE_GUILE
+ libstarparse_la_SOURCES += guile-binding.c guile-compat.h
+-libstarparse_la_CFLAGS += @GUILE_CFLAGS@
+-libstarparse_la_LDFLAGS += @GUILE_LDFLAGS@ -lpthread
++libstarparse_la_CFLAGS = @GUILE_CFLAGS@
++libstarparse_la_LIBADD = @GUILE_LIBS@ -lpthread
+ endif
+
+
+--- configure.ac
++++ configure.ac
+@@ -10,18 +10,13 @@
+
+ AM_INIT_AUTOMAKE
+
+-AC_ARG_ENABLE(guile,
++AC_ARG_ENABLE([guile],
+ AS_HELP_STRING([--enable-guile],
+- [build bindings for guile scheme interpreter]),
+- USE_GUILE=$enable_guile,
+- USE_GUILE=yes) # default value
+-
+-if test "x$USE_GUILE" = "xyes";
+-then
+- GUILE_FLAGS
+-fi
+-
+-AM_CONDITIONAL(ENABLE_GUILE, test "x$USE_GUILE" = "xyes")
++ [build bindings for guile scheme interpreter]))
++AS_IF([test "x$enable_guile" = "xyes"], [
++ PKG_CHECK_MODULES([GUILE], [guile-1.8])
++])
++AM_CONDITIONAL(ENABLE_GUILE, test "x$enable_guile" = "xyes")
+
+ AC_CONFIG_FILES([Makefile
+ starparse-env
diff --git a/sci-libs/starparse/metadata.xml b/sci-libs/starparse/metadata.xml
new file mode 100644
index 000000000000..51fdedab1b38
--- /dev/null
+++ b/sci-libs/starparse/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>sci-chemistry</herd>
+</pkgmetadata>
diff --git a/sci-libs/starparse/starparse-1.0-r1.ebuild b/sci-libs/starparse/starparse-1.0-r1.ebuild
new file mode 100644
index 000000000000..44d8c220fedf
--- /dev/null
+++ b/sci-libs/starparse/starparse-1.0-r1.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+AUTOTOOLS_AUTORECONF=yes
+
+inherit autotools-utils
+
+DESCRIPTION="Library for parsing NMR star files (peak-list format) and CIF files"
+HOMEPAGE="http://burrow-owl.sourceforge.net/"
+#SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+# Created from rev 19 @ http://oregonstate.edu/~benisong/software/projects/starparse/releases/1.0
+SRC_URI="http://dev.gentooexperimental.org/~jlec/distfiles/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="guile static-libs test"
+
+REQUIRED_USE="test? ( guile )"
+
+RDEPEND="guile? ( dev-scheme/guile:12 )"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+PATCHES=( "${FILESDIR}"/${P}-guile1.8.patch )
+
+src_configure() {
+ local myeconfargs=( $(use_enable guile) )
+ autotools-utils_src_configure
+}