summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sci-libs/pyshp')
-rw-r--r--sci-libs/pyshp/Manifest1
-rw-r--r--sci-libs/pyshp/metadata.xml10
-rw-r--r--sci-libs/pyshp/pyshp-1.2.0.ebuild28
-rw-r--r--sci-libs/pyshp/pyshp-9999.ebuild28
4 files changed, 67 insertions, 0 deletions
diff --git a/sci-libs/pyshp/Manifest b/sci-libs/pyshp/Manifest
new file mode 100644
index 000000000000..7ad8036a0dbb
--- /dev/null
+++ b/sci-libs/pyshp/Manifest
@@ -0,0 +1 @@
+DIST pyshp-1.2.0.tar.gz 58993 SHA256 16e9a9b5caae5b69149c7be09415381b61af4f85f2087d08c0698c75e70000e7 SHA512 c77e19f258ba9d2e2c480b82c342d2bbeae4b5855627aa98777fbf590e904d50045edecaa0e5ec2e03ddaaf49bf7261944fb77bcd26bf6d21e50c90c30cd0b43 WHIRLPOOL d1558ce889b5942dd8da9b61d94c2cd5fcc8e84ca8c70a756997efad2355ea0f97eb849bfd75048b30a7337973dca07dbe1be7ecf0b33a1374637accd6bc00a4
diff --git a/sci-libs/pyshp/metadata.xml b/sci-libs/pyshp/metadata.xml
new file mode 100644
index 000000000000..f829629046dd
--- /dev/null
+++ b/sci-libs/pyshp/metadata.xml
@@ -0,0 +1,10 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>slis@gentoo.org</email>
+ </maintainer>
+ <upstream>
+ <remote-id type="pypi">pyshp</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/sci-libs/pyshp/pyshp-1.2.0.ebuild b/sci-libs/pyshp/pyshp-1.2.0.ebuild
new file mode 100644
index 000000000000..dfc89c31310e
--- /dev/null
+++ b/sci-libs/pyshp/pyshp-1.2.0.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+PYTHON_COMPAT=( python{2_7,3_3,3_4} )
+
+inherit distutils-r1
+
+DESCRIPTION="Pure Python read/write support for ESRI Shapefile format"
+HOMEPAGE="https://pypi.python.org/pypi/pyshp/"
+
+if [[ ${PV} == "9999" ]] ; then
+ SRC_URI=""
+ ESVN_REPO_URI="http://${PN}.googlecode.com/svn/trunk"
+ inherit subversion
+else
+ SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+LICENSE="MIT"
+SLOT="0"
+IUSE=""
+
+RDEPEND=""
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]"
diff --git a/sci-libs/pyshp/pyshp-9999.ebuild b/sci-libs/pyshp/pyshp-9999.ebuild
new file mode 100644
index 000000000000..dfc89c31310e
--- /dev/null
+++ b/sci-libs/pyshp/pyshp-9999.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+PYTHON_COMPAT=( python{2_7,3_3,3_4} )
+
+inherit distutils-r1
+
+DESCRIPTION="Pure Python read/write support for ESRI Shapefile format"
+HOMEPAGE="https://pypi.python.org/pypi/pyshp/"
+
+if [[ ${PV} == "9999" ]] ; then
+ SRC_URI=""
+ ESVN_REPO_URI="http://${PN}.googlecode.com/svn/trunk"
+ inherit subversion
+else
+ SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+LICENSE="MIT"
+SLOT="0"
+IUSE=""
+
+RDEPEND=""
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]"