summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sci-libs/nfft/nfft-3.2.3.ebuild')
-rw-r--r--sci-libs/nfft/nfft-3.2.3.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/sci-libs/nfft/nfft-3.2.3.ebuild b/sci-libs/nfft/nfft-3.2.3.ebuild
new file mode 100644
index 000000000000..e6f5802bab27
--- /dev/null
+++ b/sci-libs/nfft/nfft-3.2.3.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+
+inherit autotools-utils toolchain-funcs
+
+DESCRIPTION="library for nonequispaced discrete Fourier transformations"
+HOMEPAGE="http://www-user.tu-chemnitz.de/~potts/nfft"
+SRC_URI="http://www-user.tu-chemnitz.de/~potts/nfft/download/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86 ~amd64"
+IUSE="openmp static-libs"
+
+RDEPEND="sci-libs/fftw:3.0[threads,openmp?]"
+DEPEND="${RDEPEND}"
+
+pkg_pretend() {
+ use openmp && ! tc-has-openmp && \
+ die "Please switch to an openmp compatible compiler"
+}
+
+src_configure() {
+ local myeconfargs=(
+ --enable-all
+ $(use_enable openmp)
+ )
+ autotools-utils_src_configure
+}