summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sci-libs/netcdf/files')
-rw-r--r--sci-libs/netcdf/files/netcdf-4.1.1-fortran.patch15
-rw-r--r--sci-libs/netcdf/files/netcdf-4.1.1-implicits.patch80
-rw-r--r--sci-libs/netcdf/files/netcdf-4.1.1-mpi-fix.patch32
-rw-r--r--sci-libs/netcdf/files/netcdf-4.1.1-parallel-build.patch40
-rw-r--r--sci-libs/netcdf/files/netcdf-4.3.2-HDF5-1.8.13+-compat.patch145
5 files changed, 312 insertions, 0 deletions
diff --git a/sci-libs/netcdf/files/netcdf-4.1.1-fortran.patch b/sci-libs/netcdf/files/netcdf-4.1.1-fortran.patch
new file mode 100644
index 000000000000..825fd3b893a1
--- /dev/null
+++ b/sci-libs/netcdf/files/netcdf-4.1.1-fortran.patch
@@ -0,0 +1,15 @@
+Default to gfortran if cannot figure out F77 compiler
+
+https://bugs.gentoo.org/show_bug.cgi?id=348922
+
+--- netcdf-4.1.1/configure.ac
++++ netcdf-4.1.1/configure.ac
+@@ -973,7 +973,7 @@
+ *)
+ # If it's a gnu compiler, guess f2c.
+ if test "x$ac_cv_fc_compiler_gnu" = xyes; then
+- AC_DEFINE(f2cFortran, [1], [Turned on by netCDF configure.])
++ AC_DEFINE(gFortran, [1], [Turned on by netCDF configure.])
+ fi
+ ;;
+ esac
diff --git a/sci-libs/netcdf/files/netcdf-4.1.1-implicits.patch b/sci-libs/netcdf/files/netcdf-4.1.1-implicits.patch
new file mode 100644
index 000000000000..a30aafc91348
--- /dev/null
+++ b/sci-libs/netcdf/files/netcdf-4.1.1-implicits.patch
@@ -0,0 +1,80 @@
+Fix implicit function declarations
+
+--- libsrc/nc.c
++++ libsrc/nc.c
+@@ -15,7 +15,7 @@
+ # include <mpp/shmem.h>
+ # include <intrinsics.h>
+ #endif
+-#ifdef HAVE_UNISTD
++#ifdef HAVE_UNISTD_H
+ #include <unistd.h>
+ #endif
+
+--- fortran/fort-nc4.c
++++ fortran/fort-nc4.c
+@@ -30,6 +30,14 @@
+ /* These are in libsrc4/nc4vars.c... */
+ int nc_inq_var_chunking_ints(int ncid, int varid, int *contiguousp, int *chunksizesp);
+ int nc_def_var_chunking_ints(int ncid, int varid, int contiguous, int *chunksizes);
++int nc_set_var_chunk_cache_ints(int ncid, int varid, int size, int nelems, int preemption);
++int nc_get_var_chunk_cache_ints(int ncid, int varid, int *sizep, int *nelemsp, int *preemptionp);
++
++/* These are in libsrc4/nc4file.c... */
++int nc_set_chunk_cache_ints(int size, int nelems, int preemption);
++int nc_get_chunk_cache_ints(int *sizep, int *nelemsp, int *preemptionp);
++int nc_create_par_fortran(const char *path, int cmode, int comm, int info, int *ncidp);
++int nc_open_par_fortran(const char *path, int mode, int comm, int info, int *ncidp);
+
+ FCALLSCFUN5(NF_INT, nc_create_par_fortran, NF_CREATE_PAR, nf_create_par,
+ STRING, FINT2CINT, FINT2CINT, FINT2CINT, PCINT2FINT)
+--- libncdap3/oc/daplex.c
++++ libncdap3/oc/daplex.c
+@@ -86,6 +86,8 @@
+ SCAN_PROG
+ };
+
++int daperror(DAPparsestate* state, const char* msg);
++
+ /**************************************************/
+
+ int
+--- libncdap3/oc/ocinternal.c
++++ libncdap3/oc/ocinternal.c
+@@ -37,6 +37,8 @@
+ #endif
+
+ extern OCnode* makeunlimiteddimension(void);
++int occurlopen(CURL** curlp);
++void occurlclose(CURL* curl);
+
+ #ifdef WIN32
+ #include <fcntl.h>
+--- libncdap3/oc/dapparse.c
++++ libncdap3/oc/dapparse.c
+@@ -11,6 +11,7 @@
+ static OCtype octypefor(Object etype);
+ static char* scopeduplicates(OClist* list);
+ static int check_int32(char* val, long* value);
++void setwordchars(DAPlexstate* lexstate, int kind);
+
+ /****************************************************/
+
+--- libncdap3/ncdap3.c
++++ libncdap3/ncdap3.c
+@@ -4,6 +4,7 @@
+ * $Id$
+ *********************************************************************/
+ #include "config.h"
++#include "netcdf3.h"
+ #include "ncdap3.h"
+ #include "dispatch3.h"
+ #include "dapdispatch3.h"
+--- libncdap3/oc/dapparselex.h
++++ libncdap3/oc/dapparselex.h
+@@ -88,4 +88,5 @@
+ extern void daplexinit(char* input, DAPlexstate** lexstatep);
+ extern void daplexcleanup(DAPlexstate** lexstatep);
+
++void dassetup(DAPparsestate* state);
+ #endif /*DAPPARSELEX_H*/
diff --git a/sci-libs/netcdf/files/netcdf-4.1.1-mpi-fix.patch b/sci-libs/netcdf/files/netcdf-4.1.1-mpi-fix.patch
new file mode 100644
index 000000000000..4656ef1e3cbc
--- /dev/null
+++ b/sci-libs/netcdf/files/netcdf-4.1.1-mpi-fix.patch
@@ -0,0 +1,32 @@
+Ensure hdf5.h is included before netcdf.h to avoid build error with openmpi >= 1.4.1
+
+--- libsrc4/nc4internal.h
++++ libsrc4/nc4internal.h
+@@ -8,13 +8,13 @@
+
+ #include <config.h>
+ #include <stdio.h>
++#include <hdf5.h>
+ #include "error.h"
+ #include <stdlib.h>
+ #include <ctype.h>
+ #include <stdarg.h>
+ #include <string.h>
+ #include "netcdf3.h"
+-#include <hdf5.h>
+ #include <netcdf.h>
+
+ #ifdef USE_PARALLEL
+--- libncdap4/ncdap4.h
++++ libncdap4/ncdap4.h
+@@ -12,9 +12,9 @@
+ #include <stdio.h>
+
+ #include "config.h"
++#include "nc4internal.h"
+ #include "netcdf.h"
+ #include "nc.h"
+-#include "nc4internal.h"
+ #include "ncdap.h"
+ #include "getvara.h"
+ #include "constraints3.h"
diff --git a/sci-libs/netcdf/files/netcdf-4.1.1-parallel-build.patch b/sci-libs/netcdf/files/netcdf-4.1.1-parallel-build.patch
new file mode 100644
index 000000000000..22708e2201e9
--- /dev/null
+++ b/sci-libs/netcdf/files/netcdf-4.1.1-parallel-build.patch
@@ -0,0 +1,40 @@
+Avoid building fortran modules twice, just install them instead.
+
+https://bugs.gentoo.org/296174
+
+--- netcdf-4.1.1/f90/Makefile.am
++++ netcdf-4.1.1/f90/Makefile.am
+@@ -101,17 +101,25 @@
+ # Some fortran compilers change the file names of .mod files to all
+ # uppercase. Just to be special.
+ if UPPER_CASE_MOD
+-nodist_include_HEADERS = TYPESIZES.mod NETCDF.mod
+-TYPESIZES.mod: typeSizes.o
+-NETCDF.mod: $(NETCDF_O)
+-BUILT_SOURCES = TYPESIZES.mod
++NETCDF_MODULES = TYPESIZES.mod NETCDF.mod
+ else
+-nodist_include_HEADERS = typesizes.mod netcdf.mod
+-typesizes.mod: typeSizes.o
+-netcdf.mod: $(NETCDF_O)
+-BUILT_SOURCES = typesizes.mod
++NETCDF_MODULES = typesizes.mod netcdf.mod
+ endif
+
++NETCDF_LO := $(NETCDF_O:.o=.lo)
++$(NETCDF_LO): typeSizes.o
++install-data-local:
++ test -z "$(includedir)" || $(MKDIR_P) "$(DESTDIR)$(includedir)"
++ @list='$(NETCDF_MODULES)'; test -n "$(includedir)" || list=; \
++ for p in $$list; do \
++ if test -f "$$p"; then d=; else d="$(srcdir)/"; fi; \
++ echo "$$d$$p"; \
++ done | $(am__base_list) | \
++ while read files; do \
++ echo " $(INSTALL_HEADER) $$files '$(DESTDIR)$(includedir)'"; \
++ $(INSTALL_HEADER) $$files "$(DESTDIR)$(includedir)" || exit $$?; \
++ done
++
+ # This is what we are building: a convenience library of F90 functions.
+ noinst_LTLIBRARIES = libnetcdff90.la
+
diff --git a/sci-libs/netcdf/files/netcdf-4.3.2-HDF5-1.8.13+-compat.patch b/sci-libs/netcdf/files/netcdf-4.3.2-HDF5-1.8.13+-compat.patch
new file mode 100644
index 000000000000..783a5b06e991
--- /dev/null
+++ b/sci-libs/netcdf/files/netcdf-4.3.2-HDF5-1.8.13+-compat.patch
@@ -0,0 +1,145 @@
+From 435d8a03ed28bb5ad63aff12cbc6ab91531b6bc8 Mon Sep 17 00:00:00 2001
+From: Quincey Koziol <quincey@koziol.cc>
+Date: Wed, 7 May 2014 08:45:15 -0500
+Subject: [PATCH] Account for the HDF5 library not having the MPI-POSIX VFD
+ configured in.
+
+---
+ RELEASE_NOTES.md | 2 ++
+ libsrc4/nc4file.c | 40 ++++++++++++++++++++++++++++++++++++++++
+ nc_test4/tst_nc4perf.c | 5 +++++
+ nc_test4/tst_parallel3.c | 5 +++++
+ 4 files changed, 52 insertions(+)
+
+diff --git a/RELEASE_NOTES.md b/RELEASE_NOTES.md
+index 27f228c..1a69d17 100644
+--- a/RELEASE_NOTES.md
++++ b/RELEASE_NOTES.md
+@@ -9,6 +9,8 @@ This file contains a high-level description of this package's evolution. Release
+
+ ### 4.3.3-rc1 Released TBD
+
++* When the NC_MPIPOSIX flag is given for parallel I/O access and the HDF5 library does not have the MPI-POSIX VFD configured in, the NC_MPIPOSIX flag is transparently aliased to the NC_MPIIO flag within the netCDF-4 library.
++
+ ## 4.3.2 Released 2014-04-23
+
+ * As part of an ongoing project, the Doxygen-generated netcdf documentation has been reorganized. The goal is to make the documentation easier to parse, and to eliminate redundant material. This project is ongoing.
+diff --git a/libsrc4/nc4file.c b/libsrc4/nc4file.c
+index ec3bb0c..5c957be 100644
+--- a/libsrc4/nc4file.c
++++ b/libsrc4/nc4file.c
+@@ -308,12 +308,21 @@ nc4_create_file(const char *path, int cmode, MPI_Comm comm, MPI_Info info,
+ if (H5Pset_fapl_mpio(fapl_id, comm, info) < 0)
+ BAIL(NC_EPARINIT);
+ }
++#ifdef USE_PARALLEL_POSIX
+ else /* MPI/POSIX */
+ {
+ LOG((4, "creating parallel file with MPI/posix"));
+ if (H5Pset_fapl_mpiposix(fapl_id, comm, 0) < 0)
+ BAIL(NC_EPARINIT);
+ }
++#else /* USE_PARALLEL_POSIX */
++ /* Should not happen! Code in NC4_create/NC4_open should alias the
++ * NC_MPIPOSIX flag to NC_MPIIO, if the MPI-POSIX VFD is not
++ * available in HDF5. -QAK
++ */
++ else /* MPI/POSIX */
++ BAIL(NC_EPARINIT);
++#endif /* USE_PARALLEL_POSIX */
+
+ /* Keep copies of the MPI Comm & Info objects */
+ if (MPI_SUCCESS != MPI_Comm_dup(comm, &nc4_info->comm))
+@@ -465,6 +474,17 @@ NC4_create(const char* path, int cmode, size_t initialsz, int basepe,
+ )
+ return NC_EINVAL;
+
++#ifndef USE_PARALLEL_POSIX
++/* If the HDF5 library has been compiled without the MPI-POSIX VFD, alias
++ * the NC_MPIPOSIX flag to NC_MPIIO. -QAK
++ */
++ if(cmode & NC_MPIPOSIX)
++ {
++ cmode &= ~NC_MPIPOSIX;
++ cmode |= NC_MPIIO;
++ }
++#endif /* USE_PARALLEL_POSIX */
++
+ cmode |= NC_NETCDF4;
+
+ /* Apply default create format. */
+@@ -2168,12 +2188,21 @@ nc4_open_file(const char *path, int mode, MPI_Comm comm,
+ if (H5Pset_fapl_mpio(fapl_id, comm, info) < 0)
+ BAIL(NC_EPARINIT);
+ }
++#ifdef USE_PARALLEL_POSIX
+ else /* MPI/POSIX */
+ {
+ LOG((4, "opening parallel file with MPI/posix"));
+ if (H5Pset_fapl_mpiposix(fapl_id, comm, 0) < 0)
+ BAIL(NC_EPARINIT);
+ }
++#else /* USE_PARALLEL_POSIX */
++ /* Should not happen! Code in NC4_create/NC4_open should alias the
++ * NC_MPIPOSIX flag to NC_MPIIO, if the MPI-POSIX VFD is not
++ * available in HDF5. -QAK
++ */
++ else /* MPI/POSIX */
++ BAIL(NC_EPARINIT);
++#endif /* USE_PARALLEL_POSIX */
+
+ /* Keep copies of the MPI Comm & Info objects */
+ if (MPI_SUCCESS != MPI_Comm_dup(comm, &nc4_info->comm))
+@@ -2640,6 +2669,17 @@ NC4_open(const char *path, int mode, int basepe, size_t *chunksizehintp,
+ (mode & NC_MPIIO && mode & NC_MPIPOSIX))
+ return NC_EINVAL;
+
++#ifndef USE_PARALLEL_POSIX
++/* If the HDF5 library has been compiled without the MPI-POSIX VFD, alias
++ * the NC_MPIPOSIX flag to NC_MPIIO. -QAK
++ */
++ if(mode & NC_MPIPOSIX)
++ {
++ mode &= ~NC_MPIPOSIX;
++ mode |= NC_MPIIO;
++ }
++#endif /* USE_PARALLEL_POSIX */
++
+
+ /* Depending on the type of file, open it. */
+
+diff --git a/nc_test4/tst_nc4perf.c b/nc_test4/tst_nc4perf.c
+index 47af70e..3528b82 100644
+--- a/nc_test4/tst_nc4perf.c
++++ b/nc_test4/tst_nc4perf.c
+@@ -244,6 +244,11 @@ int test_pio_4d(size_t cache_size, int facc_type, int access_flag, MPI_Comm comm
+ return 0;
+ }
+
++/* Note: When the MPI-POSIX VFD is not compiled in to HDF5, the NC_MPIPOSIX
++ * flag will be aliased to the NC_MPIIO flag within the library, and
++ * therefore this test will exercise the aliasing, with the MPI-IO VFD,
++ * under that configuration. -QAK
++ */
+ #define NUM_MODES 2
+ #define NUM_FACC 2
+ #define NUM_CHUNK_COMBOS_2D 3
+diff --git a/nc_test4/tst_parallel3.c b/nc_test4/tst_parallel3.c
+index 27f9c98..9fa534f 100644
+--- a/nc_test4/tst_parallel3.c
++++ b/nc_test4/tst_parallel3.c
+@@ -129,6 +129,11 @@ int main(int argc, char **argv)
+ if (mpi_rank == 0)
+ SUMMARIZE_ERR;
+
++/* Note: When the MPI-POSIX VFD is not compiled in to HDF5, the NC_MPIPOSIX
++ * flag will be aliased to the NC_MPIIO flag within the library, and
++ * therefore this test will exercise the aliasing, with the MPI-IO VFD,
++ * under that configuration. -QAK
++ */
+ if (mpi_rank == 0)
+ printf("*** Testing parallel IO for raw-data with MPIPOSIX-IO (driver)...");
+ facc_type = NC_NETCDF4|NC_MPIPOSIX;
+--
+2.0.3
+