summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sci-libs/mpir/files/mpir-2.2.0-yasm.patch')
-rw-r--r--sci-libs/mpir/files/mpir-2.2.0-yasm.patch54
1 files changed, 54 insertions, 0 deletions
diff --git a/sci-libs/mpir/files/mpir-2.2.0-yasm.patch b/sci-libs/mpir/files/mpir-2.2.0-yasm.patch
new file mode 100644
index 000000000000..e717891a4e64
--- /dev/null
+++ b/sci-libs/mpir/files/mpir-2.2.0-yasm.patch
@@ -0,0 +1,54 @@
+diff -U 3 -dHrN mpir-2.2.0.orig/configure.in mpir-2.2.0/configure.in
+--- mpir-2.2.0.orig/configure.in 2010-12-16 10:16:19.000000000 +0100
++++ mpir-2.2.0/configure.in 2010-12-16 10:16:53.000000000 +0100
+@@ -1455,8 +1455,6 @@
+ ;;
+ esac
+
+-AM_CONDITIONAL(BUILD_YASM, test "$want_yasm" = "yes")
+-
+ CFLAGS_or_unset=${CFLAGS-'(unset)'}
+ CPPFLAGS_or_unset=${CPPFLAGS-'(unset)'}
+
+@@ -1848,7 +1846,7 @@
+ GMP_CHECK_LIBM_FOR_BUILD
+
+
+-MPIR_AS="/yasm/yasm"
++MPIR_AS="yasm"
+
+ # How to assemble, used with CFLAGS etc, see mpn/Makeasm.am.
+ # Using the compiler is a lot easier than figuring out how to invoke the
+@@ -3161,9 +3159,6 @@
+ # FIXME: Upcoming version of autoconf/automake don't like broken lines.
+ # Right now automake isn't accepting the new AC_CONFIG_FILES scheme.
+
+-# allways configure all subdirectorys , even if there are not going to be built ,
+-AC_CONFIG_SUBDIRS([yasm])
+-
+ case $host in
+ *-w64-mingw*)
+ if test $enable_fat = yes; then
+diff -U 3 -dHrN mpir-2.2.0.orig/Makefile.am mpir-2.2.0/Makefile.am
+--- mpir-2.2.0.orig/Makefile.am 2010-12-16 10:16:21.000000000 +0100
++++ mpir-2.2.0/Makefile.am 2010-12-16 10:17:19.000000000 +0100
+@@ -95,10 +95,6 @@
+
+ SUBDIRS = tests
+
+-if BUILD_YASM
+-SUBDIRS += yasm
+-endif
+-
+ SUBDIRS += mpn mpz mpq mpf printf scanf cxx tune doc
+
+ EXTRA_DIST = configfsf.guess configfsf.sub .gdbinit INSTALL.autoconf
+diff -U 3 -dHrN mpir-2.2.0.orig/mpn/Makeasm.am mpir-2.2.0/mpn/Makeasm.am
+--- mpir-2.2.0.orig/mpn/Makeasm.am 2010-12-16 10:16:18.000000000 +0100
++++ mpir-2.2.0/mpn/Makeasm.am 2010-12-16 10:16:35.000000000 +0100
+@@ -112,4 +112,4 @@
+ # .as assembler, assembled with Yasm
+
+ .as.lo:
+- $(LIBTOOL) --mode=compile --tag=CC $(top_srcdir)/strip_fPIC.sh $(top_builddir)$(MPIR_AS) -I $(top_builddir) $(OBJECT_FORMAT) $(GSYM_FLAG) -o $@ `test -f '$<' || echo '$(srcdir)/'`$<
++ $(LIBTOOL) --mode=compile --tag=CC $(top_srcdir)/strip_fPIC.sh $(MPIR_AS) -I $(top_builddir) $(OBJECT_FORMAT) $(GSYM_FLAG) -o $@ `test -f '$<' || echo '$(srcdir)/'`$<