summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sci-libs/libbraiding/libbraiding-1.3.ebuild')
-rw-r--r--sci-libs/libbraiding/libbraiding-1.3.ebuild20
1 files changed, 20 insertions, 0 deletions
diff --git a/sci-libs/libbraiding/libbraiding-1.3.ebuild b/sci-libs/libbraiding/libbraiding-1.3.ebuild
new file mode 100644
index 000000000000..f0950f754d74
--- /dev/null
+++ b/sci-libs/libbraiding/libbraiding-1.3.ebuild
@@ -0,0 +1,20 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DESCRIPTION="Expose the functionality of cbraid as a shared library"
+HOMEPAGE="https://github.com/miguelmarco/libbraiding"
+
+SRC_URI="https://github.com/miguelmarco/${PN}/releases/download/${PV}/${P}.tar.gz"
+
+# A few source headers still say GPLv2, but I believe that to be an
+# oversight: https://github.com/jeanluct/cbraid/issues/4
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~riscv"
+
+src_install() {
+ default
+ find "${ED}" -name '*.la' -delete || die
+}