summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sci-libs/gerris/files/gerris-20130531-hypre-no-mpi.patch')
-rw-r--r--sci-libs/gerris/files/gerris-20130531-hypre-no-mpi.patch22
1 files changed, 22 insertions, 0 deletions
diff --git a/sci-libs/gerris/files/gerris-20130531-hypre-no-mpi.patch b/sci-libs/gerris/files/gerris-20130531-hypre-no-mpi.patch
new file mode 100644
index 000000000000..f05512efbddf
--- /dev/null
+++ b/sci-libs/gerris/files/gerris-20130531-hypre-no-mpi.patch
@@ -0,0 +1,22 @@
+patch to allow gerris to use hypre without mpi
+
+--- configure.ac 2013-05-30 23:57:18.000000000 -0700
++++ configure.ac.new 2013-07-22 13:52:36.083974663 -0700
+@@ -336,7 +336,7 @@
+
+ # Build hypre module if HYPRE is installed
+ hypre=no
+-if test "x$use_mpicc" = "xyes" ; then # HYPRE needs MPI
++# hypre does not need mpi
+ AC_CHECK_LIB(HYPRE, HYPRE_IJMatrixCreate, hypre="yes", hypre="no", [-lm])
+ if test x$hypre = xyes; then
+ AC_CHECK_HEADERS(HYPRE.h, hypre="yes", hypre="no")
+@@ -344,7 +344,7 @@
+ if test x$hypre = xno; then
+ AC_MSG_WARN([HYPRE not found. hypre Module won't be available.])
+ fi
+-fi
++
+ AM_CONDITIONAL(BUILD_HYPRE, test x$hypre = xyes)
+
+ # Build lis module if lis is installed