summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sci-libs/colpack/colpack-1.0.8.ebuild')
-rw-r--r--sci-libs/colpack/colpack-1.0.8.ebuild45
1 files changed, 45 insertions, 0 deletions
diff --git a/sci-libs/colpack/colpack-1.0.8.ebuild b/sci-libs/colpack/colpack-1.0.8.ebuild
new file mode 100644
index 000000000000..25467aeafa4e
--- /dev/null
+++ b/sci-libs/colpack/colpack-1.0.8.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+
+AUTOTOOLS_IN_SOURCE_BUILD=1
+AUTOTOOLS_AUTORECONF=1
+
+inherit eutils toolchain-funcs autotools-utils
+
+MYPN=ColPack
+
+DESCRIPTION="C++ algorithms for specialized vertex coloring problems"
+LICENSE="GPL-3 LGPL-3"
+HOMEPAGE="http://www.cscapes.org/coloringpage/software.htm"
+SRC_URI="http://www.cscapes.org/download/${MYPN}/${MYPN}-${PV}.tar.gz"
+
+SLOT="0"
+IUSE="openmp static-libs"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+
+RDEPEND=""
+DEPEND="${RDEPEND}"
+
+S="${WORKDIR}/${MYPN}-${PV}"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-1.0.6-flags.patch
+ "${FILESDIR}"/${PN}-1.0.8-no-bin.patch
+)
+
+pkg_setup() {
+ if use openmp && [[ $(tc-getCC)$ == *gcc* ]] && ! tc-has-openmp; then
+ ewarn "You are using gcc without OpenMP"
+ die "Need an OpenMP capable compiler"
+ fi
+}
+
+src_configure() {
+ local myeconfargs=(
+ $(use_enable openmp)
+ )
+ autotools-utils_src_configure
+}