summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sci-electronics/espresso-ab/espresso-ab-1.0-r3.ebuild')
-rw-r--r--sci-electronics/espresso-ab/espresso-ab-1.0-r3.ebuild26
1 files changed, 26 insertions, 0 deletions
diff --git a/sci-electronics/espresso-ab/espresso-ab-1.0-r3.ebuild b/sci-electronics/espresso-ab/espresso-ab-1.0-r3.ebuild
new file mode 100644
index 000000000000..2937cb028c81
--- /dev/null
+++ b/sci-electronics/espresso-ab/espresso-ab-1.0-r3.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit autotools flag-o-matic
+
+DESCRIPTION="POSIX compliant version of the espresso logic minimization tool"
+HOMEPAGE="http://www.cs.man.ac.uk/apt/projects/balsa/"
+SRC_URI="ftp://ftp.cs.man.ac.uk/pub/amulet/balsa/other-software/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="amd64 ~ppc ~sparc x86"
+
+src_prepare() {
+ default
+
+ # Clang 16
+ eautoreconf
+}
+
+src_configure() {
+ append-cflags "-std=gnu89"
+ default
+}