summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sci-biology/paml/paml-4.10.7.ebuild')
-rw-r--r--sci-biology/paml/paml-4.10.7.ebuild37
1 files changed, 37 insertions, 0 deletions
diff --git a/sci-biology/paml/paml-4.10.7.ebuild b/sci-biology/paml/paml-4.10.7.ebuild
new file mode 100644
index 000000000000..53a41c38fd11
--- /dev/null
+++ b/sci-biology/paml/paml-4.10.7.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit toolchain-funcs
+
+DESCRIPTION="Phylogenetic Analysis by Maximum Likelihood"
+HOMEPAGE="https://abacus.gene.ucl.ac.uk/software/paml.html"
+SRC_URI="https://github.com/abacus-gene/${PN}/archive/refs/tags/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="free-noncomm"
+SLOT="0"
+KEYWORDS="~amd64"
+
+src_configure() {
+ tc-export CC
+}
+
+src_compile() {
+ emake -C src
+}
+
+src_install() {
+ dobin src/{baseml,basemlg,codeml,evolver,pamp,mcmctree,infinitesites,yn00,chi2}
+
+ dodoc -r README.md doc/.
+
+ insinto /usr/share/${PN}/control
+ doins examples/*.ctl
+
+ insinto /usr/share/${PN}/dat
+ doins -r examples/stewart* examples/*.dat dat/.
+
+ insinto /usr/share/${PN}
+ doins -r examples
+}