summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-analyzer/multipath-tcp-tools')
-rw-r--r--net-analyzer/multipath-tcp-tools/multipath-tcp-tools-2018_p12_p21-r1.ebuild7
-rw-r--r--net-analyzer/multipath-tcp-tools/multipath-tcp-tools-999999.ebuild7
2 files changed, 10 insertions, 4 deletions
diff --git a/net-analyzer/multipath-tcp-tools/multipath-tcp-tools-2018_p12_p21-r1.ebuild b/net-analyzer/multipath-tcp-tools/multipath-tcp-tools-2018_p12_p21-r1.ebuild
index f03cf1b303bb..ad249861ca1a 100644
--- a/net-analyzer/multipath-tcp-tools/multipath-tcp-tools-2018_p12_p21-r1.ebuild
+++ b/net-analyzer/multipath-tcp-tools/multipath-tcp-tools-2018_p12_p21-r1.ebuild
@@ -1,8 +1,8 @@
-# Copyright 2021 Gentoo Authors
+# Copyright 2021-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-inherit toolchain-funcs
+inherit flag-o-matic toolchain-funcs
DESCRIPTION="Analysis tools for Multipath Transmission Control Protocol (MPTCP)"
HOMEPAGE="https://github.com/nasa/multipath-tcp-tools"
@@ -31,6 +31,9 @@ src_prepare() {
}
src_compile() {
+ # bug #861179
+ append-flags -fno-strict-aliasing
+
emake \
CXX="$(tc-getCXX)" \
CXXFLAGS="${CXXFLAGS}"
diff --git a/net-analyzer/multipath-tcp-tools/multipath-tcp-tools-999999.ebuild b/net-analyzer/multipath-tcp-tools/multipath-tcp-tools-999999.ebuild
index ba36c687bf3f..3178d81adff6 100644
--- a/net-analyzer/multipath-tcp-tools/multipath-tcp-tools-999999.ebuild
+++ b/net-analyzer/multipath-tcp-tools/multipath-tcp-tools-999999.ebuild
@@ -1,8 +1,8 @@
-# Copyright 2021 Gentoo Authors
+# Copyright 2021-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-inherit git-r3 toolchain-funcs
+inherit git-r3 flag-o-matic toolchain-funcs
DESCRIPTION="Analysis tools for Multipath Transmission Control Protocol (MPTCP)"
HOMEPAGE="https://github.com/nasa/multipath-tcp-tools"
@@ -31,6 +31,9 @@ src_prepare() {
}
src_compile() {
+ # bug #861179
+ append-flags -fno-strict-aliasing
+
emake \
CXX="$(tc-getCXX)" \
CXXFLAGS="${CXXFLAGS}"