summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-analyzer/mtr/mtr-9999.ebuild')
-rw-r--r--net-analyzer/mtr/mtr-9999.ebuild17
1 files changed, 8 insertions, 9 deletions
diff --git a/net-analyzer/mtr/mtr-9999.ebuild b/net-analyzer/mtr/mtr-9999.ebuild
index 0bc99abad64a..797b07c37320 100644
--- a/net-analyzer/mtr/mtr-9999.ebuild
+++ b/net-analyzer/mtr/mtr-9999.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2016 Gentoo Foundation
+# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
@@ -13,14 +13,14 @@ SRC_URI="mirror://gentoo/gtk-2.0-for-mtr.m4.bz2"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS=""
-IUSE="gtk ipv6"
+IUSE="gtk ipv6 ncurses"
RDEPEND="
- sys-libs/ncurses:0=
gtk? (
dev-libs/glib:2
x11-libs/gtk+:2
)
+ ncurses? ( sys-libs/ncurses:0= )
"
DEPEND="
${RDEPEND}
@@ -31,7 +31,7 @@ DEPEND="
DOCS=( AUTHORS FORMATS NEWS README SECURITY TODO )
FILECAPS=( cap_net_raw /usr/sbin/mtr )
PATCHES=(
- "${FILESDIR}"/${PN}-0.80-impl-dec.patch
+ "${FILESDIR}"/${PN}-9999-tinfo.patch
)
src_unpack() {
@@ -40,22 +40,21 @@ src_unpack() {
}
src_prepare() {
- default
-
# Keep this comment and following mv, even in case ebuild does not need
# it: kept gtk-2.0.m4 in SRC_URI but you'll have to mv it before autoreconf
mv "${WORKDIR}"/gtk-2.0-for-mtr.m4 gtk-2.0.m4 || die #222909
- eapply_user
+ default
AT_M4DIR="." eautoreconf
}
src_configure() {
# In the source's configure script -lresolv is commented out. Apparently it
- # is needed for 64bit macos still.
+ # is still needed for 64-bit MacOS.
[[ ${CHOST} == *-darwin* ]] && append-libs -lresolv
econf \
$(use_enable ipv6) \
- $(use_with gtk)
+ $(use_with gtk) \
+ $(use_with ncurses)
}