summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'mail-client/mailx-support')
-rw-r--r--mail-client/mailx-support/Manifest1
-rw-r--r--mail-client/mailx-support/files/mailx-support-20030215-gentoo.patch66
-rw-r--r--mail-client/mailx-support/files/mailx-support-20060102-add-sys_file_h.patch9
-rw-r--r--mail-client/mailx-support/files/mailx-support-20060102-respect-ldflags.patch18
-rw-r--r--mail-client/mailx-support/mailx-support-20060102-r1.ebuild38
-rw-r--r--mail-client/mailx-support/mailx-support-20060102-r2.ebuild39
-rw-r--r--mail-client/mailx-support/metadata.xml5
7 files changed, 176 insertions, 0 deletions
diff --git a/mail-client/mailx-support/Manifest b/mail-client/mailx-support/Manifest
new file mode 100644
index 000000000000..c2ff4944951e
--- /dev/null
+++ b/mail-client/mailx-support/Manifest
@@ -0,0 +1 @@
+DIST mailx-support-20060102.tar.bz2 8822 SHA256 e962d12116a99ab72cc04304cc0f9b86dce2ab84c5028599e052c21930fc4d62 SHA512 a4bd84253fcb5a97119e75290dfda01004115c3eb5898bb792c75f7b01c7e48fa1189b9ec4ed195c404196893af8b9390062f2f258da68889b464b53aa0ecbc2 WHIRLPOOL b009fc0405a9610c9ac8cd66024dc237dbc5910f9a7e9b13440a167be8a1bc751d9ce2e318008ca83d6ad5c6d8cd32a1433bb1647ab1f271da5ffe334318331a
diff --git a/mail-client/mailx-support/files/mailx-support-20030215-gentoo.patch b/mail-client/mailx-support/files/mailx-support-20030215-gentoo.patch
new file mode 100644
index 000000000000..829b85820488
--- /dev/null
+++ b/mail-client/mailx-support/files/mailx-support-20030215-gentoo.patch
@@ -0,0 +1,66 @@
+--- - 2003-02-15 23:35:46.000000000 +0800
++++ locking.c 2003-02-15 23:19:11.000000000 +0800
+@@ -45,6 +45,7 @@
+ #include <stdarg.h>
+ #include "pathnames.h"
+ #include "mail.local.h"
++#include "open_with_exlock.h"
+
+ static char lpath[MAXPATHLEN];
+
+@@ -93,7 +94,7 @@
+ }
+ goto again;
+ }
+- if ((lfd = open(lpath, O_CREAT|O_WRONLY|O_EXCL|O_EXLOCK,
++ if ((lfd = open_with_exlock(lpath, O_CREAT|O_WRONLY|O_EXCL,
+ S_IRUSR|S_IWUSR)) != -1)
+ break;
+ again:
+@@ -104,7 +105,7 @@
+ return(-1);
+ }
+ if (tries > 9 &&
+- (lfd = open(lpath, O_WRONLY|O_EXLOCK, 0)) != -1) {
++ (lfd = open_with_exlock(lpath, O_WRONLY, 0)) != -1) {
+ if (fstat(lfd, &fsb) != -1 &&
+ lstat(lpath, &sb) != -1) {
+ if (fsb.st_dev == sb.st_dev &&
+@@ -169,3 +170,4 @@
+ if (isfatal)
+ exit(1);
+ }
++
+--- - 2003-02-15 23:37:13.000000000 +0800
++++ mail.local.c 2003-02-15 23:20:50.000000000 +0800
+@@ -66,6 +66,7 @@
+ #include <string.h>
+ #include "pathnames.h"
+ #include "mail.local.h"
++#include "open_with_exlock.h"
+
+ int
+ main(int argc, char *argv[])
+@@ -218,7 +219,7 @@
+ merr(NOTFATAL, "%s: %s", path, strerror(errno));
+ goto bad;
+ }
+- if ((mbfd = open(path, O_APPEND|O_CREAT|O_EXCL|O_WRONLY|O_EXLOCK,
++ if ((mbfd = open_with_exlock(path, O_APPEND|O_CREAT|O_EXCL|O_WRONLY,
+ S_IRUSR|S_IWUSR)) < 0) {
+ if (errno == EEXIST) {
+ /* file appeared since lstat */
+@@ -244,7 +245,7 @@
+ merr(NOTFATAL, "%s: linked or special file", path);
+ goto bad;
+ }
+- if ((mbfd = open(path, O_APPEND|O_WRONLY|O_EXLOCK,
++ if ((mbfd = open_with_exlock(path, O_APPEND|O_WRONLY,
+ S_IRUSR|S_IWUSR)) < 0) {
+ merr(NOTFATAL, "%s: %s", path, strerror(errno));
+ goto bad;
+@@ -340,3 +341,4 @@
+ {
+ merr(FATAL, "usage: mail.local [-lL] [-f from] user ...");
+ }
++
diff --git a/mail-client/mailx-support/files/mailx-support-20060102-add-sys_file_h.patch b/mail-client/mailx-support/files/mailx-support-20060102-add-sys_file_h.patch
new file mode 100644
index 000000000000..b3b871b43a51
--- /dev/null
+++ b/mail-client/mailx-support/files/mailx-support-20060102-add-sys_file_h.patch
@@ -0,0 +1,9 @@
+diff -Naur mailx-support-20060102.orig/open_with_exlock.c mailx-support-20060102/open_with_exlock.c
+--- mailx-support-20060102.orig/open_with_exlock.c 2003-06-09 19:01:08.000000000 +0000
++++ mailx-support-20060102/open_with_exlock.c 2014-04-01 12:17:31.830213927 +0000
+@@ -1,4 +1,5 @@
+ #include <fcntl.h>
++#include <sys/file.h>
+
+ int open_with_exlock(const char *path, int flags, mode_t mode)
+ {
diff --git a/mail-client/mailx-support/files/mailx-support-20060102-respect-ldflags.patch b/mail-client/mailx-support/files/mailx-support-20060102-respect-ldflags.patch
new file mode 100644
index 000000000000..42aa56948c7a
--- /dev/null
+++ b/mail-client/mailx-support/files/mailx-support-20060102-respect-ldflags.patch
@@ -0,0 +1,18 @@
+Index: mailx-support-20060102/Makefile
+===================================================================
+--- mailx-support-20060102.orig/Makefile
++++ mailx-support-20060102/Makefile
+@@ -17,10 +17,10 @@ clean:
+ ${RM} -f ${PRODUCTS} *.o
+
+ mail.local: mail.local.o locking.o open_with_exlock.o
+- ${CC} ${CFLAGS} -o $@ $^
++ ${CC} ${LDFLAGS} ${CFLAGS} -o $@ $^
+
+ lockspool: lockspool.o locking.o open_with_exlock.o
+- ${CC} ${CFLAGS} -o $@ $^
++ ${CC} ${LDFLAGS} ${BINDNOW_FLAGS} ${CFLAGS} -o $@ $^
+
+ .c.o:
+ ${CC} ${CFLAGS} -c -o $@ $^
+
diff --git a/mail-client/mailx-support/mailx-support-20060102-r1.ebuild b/mail-client/mailx-support/mailx-support-20060102-r1.ebuild
new file mode 100644
index 000000000000..2ab64ae9833c
--- /dev/null
+++ b/mail-client/mailx-support/mailx-support-20060102-r1.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+inherit eutils toolchain-funcs
+
+DESCRIPTION="Provides lockspool utility"
+HOMEPAGE="http://www.openbsd.org/"
+SRC_URI="mirror://gentoo/${P}.tar.bz2"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="alpha amd64 arm hppa ia64 ~mips ppc ppc64 s390 sh sparc x86 ~amd64-linux ~arm-linux ~x86-linux ~ppc-macos ~x86-macos"
+IUSE=""
+
+RDEPEND=""
+DEPEND=""
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}"/${P}-respect-ldflags.patch
+
+ # This code should only be ran with Gentoo Prefix profiles
+ if use prefix; then
+ ebegin "Allowing unprivileged install"
+ sed -i -e "s|-g 0 -o 0||g" Makefile
+ eend $?
+ fi
+}
+
+src_compile() {
+ emake CC="$(tc-getCC)" BINDNOW_FLAGS="" || die "emake failed"
+}
+
+src_install() {
+ einstall || die "einstall failed"
+}
diff --git a/mail-client/mailx-support/mailx-support-20060102-r2.ebuild b/mail-client/mailx-support/mailx-support-20060102-r2.ebuild
new file mode 100644
index 000000000000..658f9590b57f
--- /dev/null
+++ b/mail-client/mailx-support/mailx-support-20060102-r2.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+
+inherit eutils toolchain-funcs
+
+DESCRIPTION="Provides lockspool utility"
+HOMEPAGE="http://www.openbsd.org/"
+SRC_URI="mirror://gentoo/${P}.tar.bz2"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="alpha amd64 arm hppa ia64 ~mips ppc ppc64 ~s390 ~sh sparc x86 ~amd64-linux ~arm-linux ~x86-linux ~ppc-macos ~x86-macos"
+IUSE=""
+
+RDEPEND=""
+DEPEND=""
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-respect-ldflags.patch
+ epatch "${FILESDIR}"/${P}-add-sys_file_h.patch
+
+ # This code should only be ran with Gentoo Prefix profiles
+ if use prefix; then
+ ebegin "Allowing unprivileged install"
+ sed -i -e "s|-g 0 -o 0||g" Makefile
+ eend $?
+ fi
+}
+
+src_compile() {
+ emake CC="$(tc-getCC)" BINDNOW_FLAGS="" || die "emake failed"
+}
+
+src_install() {
+ emake prefix="${D}/usr" install
+}
diff --git a/mail-client/mailx-support/metadata.xml b/mail-client/mailx-support/metadata.xml
new file mode 100644
index 000000000000..51f94e3fbe0e
--- /dev/null
+++ b/mail-client/mailx-support/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>net-mail</herd>
+</pkgmetadata>