summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-util')
-rw-r--r--dev-util/itstool/itstool-2.0.2.ebuild6
-rw-r--r--dev-util/itstool/itstool-2.0.6-r1.ebuild (renamed from dev-util/itstool/itstool-2.0.6.ebuild)4
2 files changed, 7 insertions, 3 deletions
diff --git a/dev-util/itstool/itstool-2.0.2.ebuild b/dev-util/itstool/itstool-2.0.2.ebuild
index c970a0e502df..2606e551b647 100644
--- a/dev-util/itstool/itstool-2.0.2.ebuild
+++ b/dev-util/itstool/itstool-2.0.2.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2015 Gentoo Foundation
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=5
@@ -21,7 +21,9 @@ IUSE=""
REQUIRED_USE="${PYTHON_REQUIRED_USE}"
RDEPEND="${PYTHON_DEPS}
- dev-libs/libxml2[python,${PYTHON_USEDEP}]"
+ $(python_gen_cond_dep '
+ dev-libs/libxml2[python,${PYTHON_MULTI_USEDEP}]
+ ')"
DEPEND="${RDEPEND}"
pkg_setup() {
diff --git a/dev-util/itstool/itstool-2.0.6.ebuild b/dev-util/itstool/itstool-2.0.6-r1.ebuild
index 444c8f20eec7..d277093282fd 100644
--- a/dev-util/itstool/itstool-2.0.6.ebuild
+++ b/dev-util/itstool/itstool-2.0.6-r1.ebuild
@@ -21,7 +21,9 @@ IUSE=""
REQUIRED_USE="${PYTHON_REQUIRED_USE}"
RDEPEND="${PYTHON_DEPS}
- dev-libs/libxml2[python,${PYTHON_USEDEP}]"
+ $(python_gen_cond_dep '
+ dev-libs/libxml2[python,${PYTHON_MULTI_USEDEP}]
+ ')"
DEPEND="${RDEPEND}"
BDEPEND=""