summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ruby/ruby-gtksourceview3/ruby-gtksourceview3-3.0.8.ebuild')
-rw-r--r--dev-ruby/ruby-gtksourceview3/ruby-gtksourceview3-3.0.8.ebuild40
1 files changed, 40 insertions, 0 deletions
diff --git a/dev-ruby/ruby-gtksourceview3/ruby-gtksourceview3-3.0.8.ebuild b/dev-ruby/ruby-gtksourceview3/ruby-gtksourceview3-3.0.8.ebuild
new file mode 100644
index 000000000000..02f52c0d9f91
--- /dev/null
+++ b/dev-ruby/ruby-gtksourceview3/ruby-gtksourceview3-3.0.8.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+USE_RUBY="ruby21 ruby22 ruby23"
+
+inherit virtualx ruby-ng-gnome2
+
+DESCRIPTION="Ruby Gtk3 bindings"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE=""
+
+DEPEND+=" x11-libs/gtksourceview:3.0"
+RDEPEND+=" x11-libs/gtksourceview:3.0"
+
+ruby_add_bdepend ">=dev-ruby/ruby-glib2-${PV}"
+ruby_add_rdepend ">=dev-ruby/ruby-gtk3-${PV}"
+
+all_ruby_prepare() {
+ # Avoid compilation of dependencies during test.
+ sed -i -e '/system/,/^ end/ s:^:#:' test/run-test.rb || die
+}
+
+each_ruby_configure() {
+ :
+}
+
+each_ruby_compile() {
+ :
+}
+
+each_ruby_test() {
+ VIRTUALX_COMMAND=${RUBY}
+ virtualmake test/run-test.rb || die
+}
+
+each_ruby_install() {
+ each_fakegem_install
+}