summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/pysocks/pysocks-1.7.1-r2.ebuild')
-rw-r--r--dev-python/pysocks/pysocks-1.7.1-r2.ebuild25
1 files changed, 25 insertions, 0 deletions
diff --git a/dev-python/pysocks/pysocks-1.7.1-r2.ebuild b/dev-python/pysocks/pysocks-1.7.1-r2.ebuild
new file mode 100644
index 000000000000..68c71fafd17e
--- /dev/null
+++ b/dev-python/pysocks/pysocks-1.7.1-r2.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+# please keep this ebuild at EAPI 8 -- sys-apps/portage dep
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYPI_NO_NORMALIZE=1
+PYPI_PN=PySocks
+PYTHON_COMPAT=( python3_{10..13} pypy3 )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="SOCKS client module"
+HOMEPAGE="
+ https://github.com/Anorov/PySocks/
+ https://pypi.org/project/PySocks/
+"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha amd64 arm arm64 hppa ~loong ~m68k ~mips ppc ppc64 ~riscv ~s390 sparc x86 ~amd64-linux ~x86-linux ~arm64-macos ~ppc-macos ~x64-macos ~x64-solaris"
+
+# tests are broken beyond repair and the package is no longer maintained
+RESTRICT="test"