summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/mpdlcd/mpdlcd-0.5.2.ebuild')
-rw-r--r--dev-python/mpdlcd/mpdlcd-0.5.2.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/dev-python/mpdlcd/mpdlcd-0.5.2.ebuild b/dev-python/mpdlcd/mpdlcd-0.5.2.ebuild
new file mode 100644
index 000000000000..b5e77f3dc0be
--- /dev/null
+++ b/dev-python/mpdlcd/mpdlcd-0.5.2.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6..9} )
+
+inherit distutils-r1
+
+DESCRIPTION="A small tool to display the MPD status on a LCDproc server."
+HOMEPAGE="https://github.com/rbarrois/mpdlcd"
+SRC_URI="https://github.com/rbarrois/${PN}/archive/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="dev-python/python-mpd"
+
+S="${WORKDIR}/${PN}-${P}"
+
+distutils_enable_tests pytest
+
+python_install_all() {
+ distutils-r1_python_install_all
+
+ doman man/mpdlcd.1
+
+ insinto /etc
+ doins mpdlcd.conf
+
+ newinitd "${FILESDIR}"/mpdlcd.initd mpdlcd
+ newconfd "${FILESDIR}"/mpdlcd.confd mpdlcd
+}