summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/moto/moto-0.4.30.ebuild')
-rw-r--r--dev-python/moto/moto-0.4.30.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/dev-python/moto/moto-0.4.30.ebuild b/dev-python/moto/moto-0.4.30.ebuild
new file mode 100644
index 000000000000..8c1f98b980b9
--- /dev/null
+++ b/dev-python/moto/moto-0.4.30.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+PYTHON_COMPAT=( python{2_7,3_4} )
+
+inherit distutils-r1
+
+DESCRIPTION="Mock library for boto"
+HOMEPAGE="https://github.com/spulec/moto"
+SRC_URI="mirror://pypi/${P:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+RDEPEND=">=dev-python/jinja-2.8[${PYTHON_USEDEP}]
+ >=dev-python/boto-2.36.0[${PYTHON_USEDEP}]
+ dev-python/flask[${PYTHON_USEDEP}]
+ >=dev-python/httpretty-0.8.10[${PYTHON_USEDEP}]
+ dev-python/requests[${PYTHON_USEDEP}]
+ dev-python/xmltodict[${PYTHON_USEDEP}]
+ dev-python/six[${PYTHON_USEDEP}]
+ dev-python/werkzeug[${PYTHON_USEDEP}]"
+
+python_prepare_all() {
+ distutils-r1_python_prepare_all
+ sed -e "s/httpretty==0.8.10/httpretty>=0.8.10/" -i setup.py
+
+}