summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/jupyterlab-lsp')
-rw-r--r--dev-python/jupyterlab-lsp/Manifest1
-rw-r--r--dev-python/jupyterlab-lsp/jupyterlab-lsp-5.0.1.ebuild26
2 files changed, 27 insertions, 0 deletions
diff --git a/dev-python/jupyterlab-lsp/Manifest b/dev-python/jupyterlab-lsp/Manifest
index 1184776e05fe..ec7ed5ec374d 100644
--- a/dev-python/jupyterlab-lsp/Manifest
+++ b/dev-python/jupyterlab-lsp/Manifest
@@ -1 +1,2 @@
DIST jupyterlab-lsp-5.0.0.tar.gz 753429 BLAKE2B bd9fac94edea990943ce839c773270f14a5afd646b312c3c6888a0230c2846968388862c01c4954830d85c3eebcd6699aed79cc7861e4fb8d19d576cf0ba938b SHA512 a6e586cf19707a6aec91f495fbb437ce2aaa6b827964c06d4479d056b0a8eca525c46a3e3e8c7891e0f486cde9b63416a80188c623f71948e4b1658a751d98b1
+DIST jupyterlab-lsp-5.0.1.tar.gz 755832 BLAKE2B d8082aaf9c1219fedeebd6a717b81f08a7bba2a8618dc99b2ecf9a6d28c4e6cbf34b711c4fae4a847675ea05d2dc7acd0c812a772e9d51f37f563d088398c088 SHA512 7fef1ab7309978aa9185afdc895a7adefc72210842228d055150b231b70980e772abf166762820971f653cf0f5abd65e9bdfe3a206c4aed99b4586fec684399e
diff --git a/dev-python/jupyterlab-lsp/jupyterlab-lsp-5.0.1.ebuild b/dev-python/jupyterlab-lsp/jupyterlab-lsp-5.0.1.ebuild
new file mode 100644
index 000000000000..41562289e7f4
--- /dev/null
+++ b/dev-python/jupyterlab-lsp/jupyterlab-lsp-5.0.1.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYPI_NO_NORMALIZE=1
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Coding assistance for JupyterLab with Language Server Protocol"
+HOMEPAGE="
+ https://github.com/jupyter-lsp/jupyterlab-lsp/
+ https://pypi.org/project/jupyterlab-lsp/
+"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64"
+
+RDEPEND="
+ >=dev-python/jupyterlab-4.0.0[${PYTHON_USEDEP}]
+ <dev-python/jupyterlab-5.0.0[${PYTHON_USEDEP}]
+ >=dev-python/jupyter-lsp-2.0.0[${PYTHON_USEDEP}]
+"