summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-php/PEAR-Crypt_HMAC2')
-rw-r--r--dev-php/PEAR-Crypt_HMAC2/Manifest1
-rw-r--r--dev-php/PEAR-Crypt_HMAC2/PEAR-Crypt_HMAC2-1.0.0.ebuild28
-rw-r--r--dev-php/PEAR-Crypt_HMAC2/metadata.xml5
3 files changed, 34 insertions, 0 deletions
diff --git a/dev-php/PEAR-Crypt_HMAC2/Manifest b/dev-php/PEAR-Crypt_HMAC2/Manifest
new file mode 100644
index 000000000000..b7c83d603eaa
--- /dev/null
+++ b/dev-php/PEAR-Crypt_HMAC2/Manifest
@@ -0,0 +1 @@
+DIST Crypt_HMAC2-1.0.0.tgz 8129 SHA256 6b616cd6c2a6c3937c5790d7ffa4ef917d3db2bba7310f86111f1e514432ed2b SHA512 0c3bd71ba8c2bf086ca703732fb3ee2471797ea486dbc863acbb5d07426395a65b8c794473ac4b1c1b85e954e27b79361116bee0a36f4b78edd780ea6c06bfca WHIRLPOOL ca09a86dbf7b00079dc1638e38b2439ba08ab467934374f5cb78c648929c07eb2fa75a0d327e915a7e2aed69c964e471d3bedd772743886cfba84a0e4794a31a
diff --git a/dev-php/PEAR-Crypt_HMAC2/PEAR-Crypt_HMAC2-1.0.0.ebuild b/dev-php/PEAR-Crypt_HMAC2/PEAR-Crypt_HMAC2-1.0.0.ebuild
new file mode 100644
index 000000000000..da0e1ec44d58
--- /dev/null
+++ b/dev-php/PEAR-Crypt_HMAC2/PEAR-Crypt_HMAC2-1.0.0.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="4"
+
+inherit php-pear-r1
+
+DESCRIPTION="Implementation of Hashed Message Authentication Code for PHP5"
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+src_install() {
+ php-pear-r1_src_install
+
+ #Useless file that often conflicts with other packages
+ rm "${D}/usr/share/php/generate_package_xml.php"
+}
+
+pkg_postinst() {
+ if ! has_version "dev-lang/php[hash]" ; then
+ elog "${PN} can use the hash extension when enabled to extend the range"
+ elog "of cryptographic hash functions beyond the natively implemented MD5 and SHA1."
+ elog "Recompile dev-lang/php with USE=\"hash\" if you want these features."
+ fi
+}
diff --git a/dev-php/PEAR-Crypt_HMAC2/metadata.xml b/dev-php/PEAR-Crypt_HMAC2/metadata.xml
new file mode 100644
index 000000000000..fd3dbe39fa64
--- /dev/null
+++ b/dev-php/PEAR-Crypt_HMAC2/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>php</herd>
+</pkgmetadata>