summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-libs/cpuinfo/cpuinfo-2024.10.22.1.ebuild')
-rw-r--r--dev-libs/cpuinfo/cpuinfo-2024.10.22.1.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/dev-libs/cpuinfo/cpuinfo-2024.10.22.1.ebuild b/dev-libs/cpuinfo/cpuinfo-2024.10.22.1.ebuild
new file mode 100644
index 000000000000..43cb3b1940fd
--- /dev/null
+++ b/dev-libs/cpuinfo/cpuinfo-2024.10.22.1.ebuild
@@ -0,0 +1,35 @@
+# Copyright 2022-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+inherit cmake
+
+CommitId=094fc30b9256f54dad5ad23bcbfb5de74781422f
+
+DESCRIPTION="CPU INFOrmation library"
+HOMEPAGE="https://github.com/pytorch/cpuinfo/"
+SRC_URI="https://github.com/pytorch/${PN}/archive/${CommitId}.tar.gz
+ -> ${P}.tar.gz"
+
+S="${WORKDIR}"/${PN}-${CommitId}
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="test"
+
+BDEPEND="test? ( dev-cpp/gtest )"
+RESTRICT="!test? ( test )"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-2023.11.04-gentoo.patch
+ "${FILESDIR}"/${PN}-2023.01.13-test.patch
+)
+
+src_configure() {
+ local mycmakeargs=(
+ -DCPUINFO_BUILD_BENCHMARKS=OFF
+ -DCPUINFO_BUILD_UNIT_TESTS=$(usex test ON OFF)
+ )
+ cmake_src_configure
+}