summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-cpp')
-rw-r--r--dev-cpp/cpp-taskflow/cpp-taskflow-3.2.0.ebuild3
-rw-r--r--dev-cpp/cpp-taskflow/cpp-taskflow-9999.ebuild3
2 files changed, 4 insertions, 2 deletions
diff --git a/dev-cpp/cpp-taskflow/cpp-taskflow-3.2.0.ebuild b/dev-cpp/cpp-taskflow/cpp-taskflow-3.2.0.ebuild
index e4f2f9e403b5..9b146d9dc546 100644
--- a/dev-cpp/cpp-taskflow/cpp-taskflow-3.2.0.ebuild
+++ b/dev-cpp/cpp-taskflow/cpp-taskflow-3.2.0.ebuild
@@ -10,7 +10,6 @@ HOMEPAGE="https://cpp-taskflow.github.io"
if [[ ${PV} == 9999 ]]; then
EGIT_REPO_URI="https://github.com/cpp-taskflow/${PN}.git"
inherit git-r3
- KEYWORDS=""
S="${WORKDIR}/cpp-taskflow-${PV}"
else
SRC_URI="https://github.com/${PN}/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
@@ -23,6 +22,8 @@ SLOT="0"
IUSE="examples test"
RESTRICT="!test? ( test )"
+DEPEND="test? ( dev-cpp/doctest )"
+
HTML_DOCS=( docs/. )
src_prepare() {
diff --git a/dev-cpp/cpp-taskflow/cpp-taskflow-9999.ebuild b/dev-cpp/cpp-taskflow/cpp-taskflow-9999.ebuild
index e4f2f9e403b5..9b146d9dc546 100644
--- a/dev-cpp/cpp-taskflow/cpp-taskflow-9999.ebuild
+++ b/dev-cpp/cpp-taskflow/cpp-taskflow-9999.ebuild
@@ -10,7 +10,6 @@ HOMEPAGE="https://cpp-taskflow.github.io"
if [[ ${PV} == 9999 ]]; then
EGIT_REPO_URI="https://github.com/cpp-taskflow/${PN}.git"
inherit git-r3
- KEYWORDS=""
S="${WORKDIR}/cpp-taskflow-${PV}"
else
SRC_URI="https://github.com/${PN}/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
@@ -23,6 +22,8 @@ SLOT="0"
IUSE="examples test"
RESTRICT="!test? ( test )"
+DEPEND="test? ( dev-cpp/doctest )"
+
HTML_DOCS=( docs/. )
src_prepare() {