summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-text/bibclean')
-rw-r--r--app-text/bibclean/Manifest1
-rw-r--r--app-text/bibclean/bibclean-2.11.4.ebuild33
-rw-r--r--app-text/bibclean/files/bibclean-2.11.4-ldflags.patch13
-rw-r--r--app-text/bibclean/metadata.xml5
4 files changed, 52 insertions, 0 deletions
diff --git a/app-text/bibclean/Manifest b/app-text/bibclean/Manifest
new file mode 100644
index 000000000000..88df903343fa
--- /dev/null
+++ b/app-text/bibclean/Manifest
@@ -0,0 +1 @@
+DIST bibclean-2.11.4.tar.bz2 1244790 SHA256 cb38bcee5db50efe0135dd0499e2adf75574012467c1c6f72a63799198361225 SHA512 e04f785ca017148600984a852e3093b86eb3ca1c67f41427556d2b08e57e11f05502db5a5beb868a33780a12ee06dc7f5eb9cf794c8f7346cfce582e4761ce14 WHIRLPOOL 59fd63259bfbddb855a571777d840a6562ad9d99788a5e60e822cfdd1baafd544991b5aff8da7078e83f8c54d9ff58cb101531600fd36f423c7dbb633d97f1b4
diff --git a/app-text/bibclean/bibclean-2.11.4.ebuild b/app-text/bibclean/bibclean-2.11.4.ebuild
new file mode 100644
index 000000000000..4ee2a5f23d54
--- /dev/null
+++ b/app-text/bibclean/bibclean-2.11.4.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+inherit toolchain-funcs eutils
+
+DESCRIPTION="BibTeX bibliography prettyprinter and syntax checker"
+SRC_URI="http://www.math.utah.edu/pub/bibclean/${P}.tar.bz2"
+HOMEPAGE="http://www.math.utah.edu/pub/bibclean/"
+
+# http://packages.debian.org/changelogs/pool/main/b/bibclean/bibclean_2.11.4-5/bibclean.copyright
+LICENSE="GPL-2"
+KEYWORDS="~x86 ~amd64"
+IUSE=""
+
+SLOT="0"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}/${P}-ldflags.patch"
+}
+
+src_compile() {
+ tc-export CC CXX
+ econf
+ emake LDFLAGS="${LDFLAGS}" || die "emake failed"
+}
+
+src_install() {
+ dobin bibclean
+ newman bibclean.man bibclean.1
+}
diff --git a/app-text/bibclean/files/bibclean-2.11.4-ldflags.patch b/app-text/bibclean/files/bibclean-2.11.4-ldflags.patch
new file mode 100644
index 000000000000..e93c3be91030
--- /dev/null
+++ b/app-text/bibclean/files/bibclean-2.11.4-ldflags.patch
@@ -0,0 +1,13 @@
+Index: bibclean-2.11.4/Makefile.in
+===================================================================
+--- bibclean-2.11.4.orig/Makefile.in
++++ bibclean-2.11.4/Makefile.in
+@@ -343,7 +343,7 @@ BIBCLEAN-OBJS = bibclean.o chek.o do.o
+ $(LIBOBJS)
+
+ bibclean: $(BIBCLEAN-OBJS)
+- $(CC) -o bibclean $(CFLAGS) $(BIBCLEAN-OBJS) $(LIBS)
++ $(CC) $(LDFLAGS) -o bibclean $(CFLAGS) $(BIBCLEAN-OBJS) $(LIBS)
+
+ # This target converts the option descriptions from the manual pages
+ # to C code for inclusion in bibclean.c. The first awk command
diff --git a/app-text/bibclean/metadata.xml b/app-text/bibclean/metadata.xml
new file mode 100644
index 000000000000..ba6a8a8800d5
--- /dev/null
+++ b/app-text/bibclean/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>tex</herd>
+</pkgmetadata>