summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-crypt')
-rw-r--r--app-crypt/libb2/libb2-0.98.1-r3.ebuild4
1 files changed, 3 insertions, 1 deletions
diff --git a/app-crypt/libb2/libb2-0.98.1-r3.ebuild b/app-crypt/libb2/libb2-0.98.1-r3.ebuild
index f810cc600ecf..0137d18d8f28 100644
--- a/app-crypt/libb2/libb2-0.98.1-r3.ebuild
+++ b/app-crypt/libb2/libb2-0.98.1-r3.ebuild
@@ -3,7 +3,7 @@
EAPI=7
-inherit autotools multilib-minimal toolchain-funcs
+inherit autotools multilib-minimal toolchain-funcs flag-o-matic
DESCRIPTION="C library providing BLAKE2b, BLAKE2s, BLAKE2bp, BLAKE2sp"
HOMEPAGE="https://github.com/BLAKE2/libb2"
@@ -40,6 +40,8 @@ src_prepare() {
sed -i -e 's/ == / = /' configure.ac || die
# https://github.com/BLAKE2/libb2/pull/28
echo 'libb2_la_LDFLAGS = -no-undefined' >> src/Makefile.am || die
+ # make memset_s available
+ [[ ${CHOST} == *-solaris* ]] && append-cppflags -D__STDC_WANT_LIB_EXT1__=1
eautoreconf # upstream doesn't make releases
}