summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--x11-plugins/wmapm/files/wmapm-3.1-fno-common.patch23
-rw-r--r--x11-plugins/wmapm/wmapm-3.1-r2.ebuild5
2 files changed, 27 insertions, 1 deletions
diff --git a/x11-plugins/wmapm/files/wmapm-3.1-fno-common.patch b/x11-plugins/wmapm/files/wmapm-3.1-fno-common.patch
new file mode 100644
index 000000000000..74b8cb1c9c91
--- /dev/null
+++ b/x11-plugins/wmapm/files/wmapm-3.1-fno-common.patch
@@ -0,0 +1,23 @@
+diff -Naur wmapm-3.1.orig/wmgeneral/wmgeneral.c wmapm-3.1/wmgeneral/wmgeneral.c
+--- wmapm-3.1.orig/wmgeneral/wmgeneral.c 1998-08-04 03:49:00.000000000 +0200
++++ wmapm-3.1/wmgeneral/wmgeneral.c 2020-06-13 10:46:38.921354685 +0200
+@@ -50,6 +50,7 @@
+ GC NormalGC;
+ XpmIcon wmgen;
+ Pixmap pixmask;
++Display *display;
+
+ /*****************/
+ /* Mouse Regions */
+diff -Naur wmapm-3.1.orig/wmgeneral/wmgeneral.h wmapm-3.1/wmgeneral/wmgeneral.h
+--- wmapm-3.1.orig/wmgeneral/wmgeneral.h 1998-08-04 03:49:00.000000000 +0200
++++ wmapm-3.1/wmgeneral/wmgeneral.h 2020-06-13 10:46:31.276348472 +0200
+@@ -28,7 +28,7 @@
+ /* Global variable */
+ /*******************/
+
+-Display *display;
++extern Display *display;
+
+ /***********************/
+ /* Function Prototypes */
diff --git a/x11-plugins/wmapm/wmapm-3.1-r2.ebuild b/x11-plugins/wmapm/wmapm-3.1-r2.ebuild
index 870dfd26f77c..90652b1aee08 100644
--- a/x11-plugins/wmapm/wmapm-3.1-r2.ebuild
+++ b/x11-plugins/wmapm/wmapm-3.1-r2.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2018 Gentoo Authors
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -26,6 +26,9 @@ src_prepare() {
#Respect LDFLAGS, see bug #334747
sed -i 's/ -o wmapm/ ${LDFLAGS} -o wmapm/' "Makefile"
default
+
+ pushd "${WORKDIR}"/${P} || die
+ eapply "${FILESDIR}"/${P}-fno-common.patch
}
src_compile() {