summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--sys-devel/autoconf-vanilla/autoconf-vanilla-2.13.ebuild2
-rw-r--r--sys-devel/autoconf-vanilla/autoconf-vanilla-2.69.ebuild11
-rw-r--r--sys-devel/autoconf-vanilla/autoconf-vanilla-2.71.ebuild3
-rw-r--r--sys-devel/autoconf-vanilla/autoconf-vanilla-2.72c.ebuild4
-rw-r--r--sys-devel/autoconf-vanilla/autoconf-vanilla-9999.ebuild2
-rw-r--r--sys-devel/autoconf-vanilla/files/autoconf-2.71-conflicts.patch47
-rw-r--r--sys-devel/autoconf-vanilla/files/autoconf-2.72c-conflicts.patch48
7 files changed, 116 insertions, 1 deletions
diff --git a/sys-devel/autoconf-vanilla/autoconf-vanilla-2.13.ebuild b/sys-devel/autoconf-vanilla/autoconf-vanilla-2.13.ebuild
index d64e6199a1de..603a1a174c94 100644
--- a/sys-devel/autoconf-vanilla/autoconf-vanilla-2.13.ebuild
+++ b/sys-devel/autoconf-vanilla/autoconf-vanilla-2.13.ebuild
@@ -53,6 +53,6 @@ src_configure() {
toolchain-autoconf_src_configure \
--exec-prefix="${EPREFIX}"/usr \
--bindir="${EPREFIX}"/usr/bin \
- --datadir="${EPREFIX}"/usr/share/${MY_P} \
+ --datadir="${EPREFIX}"/usr/share/"${P}" \
--infodir="${TC_AUTOCONF_INFOPATH}"
}
diff --git a/sys-devel/autoconf-vanilla/autoconf-vanilla-2.69.ebuild b/sys-devel/autoconf-vanilla/autoconf-vanilla-2.69.ebuild
index bd7c8e898fa5..6bc5388cd225 100644
--- a/sys-devel/autoconf-vanilla/autoconf-vanilla-2.69.ebuild
+++ b/sys-devel/autoconf-vanilla/autoconf-vanilla-2.69.ebuild
@@ -51,6 +51,8 @@ PATCHES=(
"${WORKDIR}"/patches/${MY_P}-texinfo.patch
)
+TC_AUTOCONF_ENVPREFIX=07
+
src_prepare() {
# usr/bin/libtool is provided by binutils-apple, need gnu libtool
if [[ ${CHOST} == *-darwin* ]] ; then
@@ -65,4 +67,13 @@ src_prepare() {
# Restore timestamp to avoid makeinfo call
# We already have an up to date autoconf.info page at this point.
touch -r doc/{old_,}autoconf.texi || die
+
+ # This version uses recursive makefiles. As this code is dead by
+ # now, and this 'fix' is getting hacked in from the future back into
+ # the past, I doubt that the sins committed below will have a wide
+ # impact. Don't copy this code.
+ find . \
+ -name Makefile.in \
+ -execdir sed -i '/^pkgdatadir/s/@PACKAGE@/&-vanilla/g' {} + \
+ || die
}
diff --git a/sys-devel/autoconf-vanilla/autoconf-vanilla-2.71.ebuild b/sys-devel/autoconf-vanilla/autoconf-vanilla-2.71.ebuild
index 02255def2731..7a85a49cd4ae 100644
--- a/sys-devel/autoconf-vanilla/autoconf-vanilla-2.71.ebuild
+++ b/sys-devel/autoconf-vanilla/autoconf-vanilla-2.71.ebuild
@@ -45,8 +45,11 @@ PATCHES=(
"${FILESDIR}"/${MY_P}-AC_LANG_CALL_C_cxx.patch
"${FILESDIR}"/${MY_P}-time.patch
"${FILESDIR}"/${MY_P}-make-4.4.patch
+ "${FILESDIR}"/"${MY_P}"-conflicts.patch
)
+TC_AUTOCONF_ENVPREFIX=07
+
src_prepare() {
# usr/bin/libtool is provided by binutils-apple, need gnu libtool
if [[ ${CHOST} == *-darwin* ]] ; then
diff --git a/sys-devel/autoconf-vanilla/autoconf-vanilla-2.72c.ebuild b/sys-devel/autoconf-vanilla/autoconf-vanilla-2.72c.ebuild
index eab283a242b6..a678cada264c 100644
--- a/sys-devel/autoconf-vanilla/autoconf-vanilla-2.72c.ebuild
+++ b/sys-devel/autoconf-vanilla/autoconf-vanilla-2.72c.ebuild
@@ -47,6 +47,10 @@ RDEPEND="
[[ ${PV} == 9999 ]] && BDEPEND+=" >=sys-apps/texinfo-4.3"
PDEPEND="emacs? ( app-emacs/autoconf-mode )"
+PATCHES=(
+ "${FILESDIR}"/"${MY_P}"-conflicts.patch
+)
+
src_prepare() {
if [[ ${PV} == *9999 ]] ; then
# Avoid the "dirty" suffix in the git version by generating it
diff --git a/sys-devel/autoconf-vanilla/autoconf-vanilla-9999.ebuild b/sys-devel/autoconf-vanilla/autoconf-vanilla-9999.ebuild
index eab283a242b6..2386d2432452 100644
--- a/sys-devel/autoconf-vanilla/autoconf-vanilla-9999.ebuild
+++ b/sys-devel/autoconf-vanilla/autoconf-vanilla-9999.ebuild
@@ -47,6 +47,8 @@ RDEPEND="
[[ ${PV} == 9999 ]] && BDEPEND+=" >=sys-apps/texinfo-4.3"
PDEPEND="emacs? ( app-emacs/autoconf-mode )"
+TC_AUTOCONF_ENVPREFIX=07
+
src_prepare() {
if [[ ${PV} == *9999 ]] ; then
# Avoid the "dirty" suffix in the git version by generating it
diff --git a/sys-devel/autoconf-vanilla/files/autoconf-2.71-conflicts.patch b/sys-devel/autoconf-vanilla/files/autoconf-2.71-conflicts.patch
new file mode 100644
index 000000000000..d9829d1ae213
--- /dev/null
+++ b/sys-devel/autoconf-vanilla/files/autoconf-2.71-conflicts.patch
@@ -0,0 +1,47 @@
+From 0d784a60bb65eb730a1b5f2b24887192d058629b Mon Sep 17 00:00:00 2001
+From: =?UTF-8?q?Arsen=20Arsenovi=C4=87?= <arsen@gentoo.org>
+Date: Sat, 4 Nov 2023 00:32:48 +0100
+Subject: [PATCH] Append '-vanilla' to pkgdatadir
+
+---
+ Makefile.am | 3 +++
+ Makefile.in | 2 +-
+ 2 files changed, 4 insertions(+), 1 deletion(-)
+
+diff --git a/Makefile.am b/Makefile.am
+index 17e1f8f..73d2ea7 100644
+--- a/Makefile.am
++++ b/Makefile.am
+@@ -18,6 +18,9 @@
+
+ ACLOCAL_AMFLAGS = -I m4
+
++# Work around file conflicts against sys-devel/autoconf -- Arsen
++pkgdatadir = $(datadir)/@PACKAGE@-vanilla-@VERSION@
++
+ ## All of these will be incrementally updated later, here or in included
+ ## makefile fragments.
+ ETAGS_ARGS =
+diff --git a/Makefile.in b/Makefile.in
+index dcd27f7..704248f 100644
+--- a/Makefile.in
++++ b/Makefile.in
+@@ -195,7 +195,6 @@ am__make_running_with_option = \
+ test $$has_opt = yes
+ am__make_dryrun = (target_option=n; $(am__make_running_with_option))
+ am__make_keepgoing = (target_option=k; $(am__make_running_with_option))
+-pkgdatadir = $(datadir)/@PACKAGE@-@VERSION@
+ pkgincludedir = $(includedir)/@PACKAGE@
+ pkglibdir = $(libdir)/@PACKAGE@
+ pkglibexecdir = $(libexecdir)/@PACKAGE@
+@@ -401,6 +400,7 @@ distuninstallcheck_listfiles = find . -type f -print
+ am__distuninstallcheck_listfiles = $(distuninstallcheck_listfiles) \
+ | sed 's|^\./|$(prefix)/|' | grep -v '$(infodir)/dir$$'
+ distcleancheck_listfiles = find . -type f -print
++pkgdatadir = $(datadir)/@PACKAGE@-vanilla-@VERSION@
+ ACLOCAL = @ACLOCAL@
+ AMTAR = @AMTAR@
+ AM_DEFAULT_VERBOSITY = @AM_DEFAULT_VERBOSITY@
+--
+2.42.0
+
diff --git a/sys-devel/autoconf-vanilla/files/autoconf-2.72c-conflicts.patch b/sys-devel/autoconf-vanilla/files/autoconf-2.72c-conflicts.patch
new file mode 100644
index 000000000000..2ff6418a3a34
--- /dev/null
+++ b/sys-devel/autoconf-vanilla/files/autoconf-2.72c-conflicts.patch
@@ -0,0 +1,48 @@
+From 8eee2e2b910c6c3d837a4708d4d5d3d80afd8ef9 Mon Sep 17 00:00:00 2001
+From: Arsen Arsenović <arsen@gentoo.org>
+Date: Sat, 4 Nov 2023 00:20:05 +0100
+Subject: [PATCH] Append '-vanilla' to pkgdatadir
+
+---
+ Makefile.am | 3 +++
+ Makefile.in | 3 ++-
+ 2 files changed, 5 insertions(+), 1 deletion(-)
+
+diff --git a/Makefile.am b/Makefile.am
+index 28bb494..dfc8932 100644
+--- a/Makefile.am
++++ b/Makefile.am
+@@ -18,6 +18,9 @@
+
+ ACLOCAL_AMFLAGS = -I m4
+
++# Work around file conflicts against sys-devel/autoconf -- Arsen
++pkgdatadir = $(datadir)/@PACKAGE@-vanilla-@VERSION@
++
+ ## All of these will be incrementally updated later, here or in included
+ ## makefile fragments.
+ ETAGS_ARGS =
+diff --git a/Makefile.in b/Makefile.in
+index 2cde4d0..cf17242 100644
+--- a/Makefile.in
++++ b/Makefile.in
+@@ -197,7 +197,6 @@ am__make_dryrun = (target_option=n; $(am__make_running_with_option))
+ am__make_keepgoing = (target_option=k; $(am__make_running_with_option))
+ am__rm_f = rm -f $(am__rm_f_notfound)
+ am__rm_rf = rm -rf $(am__rm_f_notfound)
+-pkgdatadir = $(datadir)/@PACKAGE@-@VERSION@
+ pkgincludedir = $(includedir)/@PACKAGE@
+ pkglibdir = $(libdir)/@PACKAGE@
+ pkglibexecdir = $(libexecdir)/@PACKAGE@
+@@ -401,6 +400,8 @@ am__distuninstallcheck_listfiles = $(distuninstallcheck_listfiles) \
+ distcleancheck_listfiles = \
+ find . \( -type f -a \! \
+ \( -name .nfs* -o -name .smb* -o -name .__afs* \) \) -print
++# Work around file conflicts against sys-devel/autoconf -- Arsen
++pkgdatadir = $(datadir)/@PACKAGE@-vanilla-@VERSION@
+ ACLOCAL = @ACLOCAL@
+ AMTAR = @AMTAR@
+ AM_DEFAULT_VERBOSITY = @AM_DEFAULT_VERBOSITY@
+--
+2.42.0
+