summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--games-emulation/pcsx2/pcsx2-1.6.0-r3.ebuild4
-rw-r--r--games-emulation/pcsx2/pcsx2-9999.ebuild4
2 files changed, 2 insertions, 6 deletions
diff --git a/games-emulation/pcsx2/pcsx2-1.6.0-r3.ebuild b/games-emulation/pcsx2/pcsx2-1.6.0-r3.ebuild
index 8a6662ae3aa4..763aa3e53529 100644
--- a/games-emulation/pcsx2/pcsx2-1.6.0-r3.ebuild
+++ b/games-emulation/pcsx2/pcsx2-1.6.0-r3.ebuild
@@ -53,9 +53,7 @@ pkg_setup() {
if [[ ${MERGE_TYPE} != binary && $(tc-getCC) == *gcc* ]]; then
# -mxsave flag is needed when GCC >= 8.2 is used
# https://bugs.gentoo.org/685156
- if [[ $(gcc-major-version) -gt 8 || $(gcc-major-version) == 8 && $(gcc-minor-version) -ge 2 ]]; then
- append-flags -mxsave
- fi
+ append-flags -mxsave
fi
}
diff --git a/games-emulation/pcsx2/pcsx2-9999.ebuild b/games-emulation/pcsx2/pcsx2-9999.ebuild
index 8c462bcb79c6..0d816ee8c404 100644
--- a/games-emulation/pcsx2/pcsx2-9999.ebuild
+++ b/games-emulation/pcsx2/pcsx2-9999.ebuild
@@ -64,9 +64,7 @@ pkg_setup() {
if [[ ${MERGE_TYPE} != binary && $(tc-getCC) == *gcc* ]]; then
# -mxsave flag is needed when GCC >= 8.2 is used
# https://bugs.gentoo.org/685156
- if [[ $(gcc-major-version) -gt 8 || $(gcc-major-version) == 8 && $(gcc-minor-version) -ge 2 ]]; then
- append-flags -mxsave
- fi
+ append-flags -mxsave
fi
}