summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--net-analyzer/greenbone-security-assistant/files/greenbone-security-assistant-9.0.1-glibc_siglist.patch14
-rw-r--r--net-analyzer/greenbone-security-assistant/greenbone-security-assistant-9.0.1.ebuild4
2 files changed, 17 insertions, 1 deletions
diff --git a/net-analyzer/greenbone-security-assistant/files/greenbone-security-assistant-9.0.1-glibc_siglist.patch b/net-analyzer/greenbone-security-assistant/files/greenbone-security-assistant-9.0.1-glibc_siglist.patch
new file mode 100644
index 000000000000..f9f587c96c8c
--- /dev/null
+++ b/net-analyzer/greenbone-security-assistant/files/greenbone-security-assistant-9.0.1-glibc_siglist.patch
@@ -0,0 +1,14 @@
+#-------------------------------------------------------------------
+# compatibility with glibc 2.32 version #751592
+#-------------------------------------------------------------------
+--- ./gsad/src/gsad.c 2020-05-13 09:22:13.000000000 +0200
++++ ./gsad/src/gsad.c 2020-10-28 13:07:25.127222254 +0100
+@@ -3318,7 +3318,7 @@
+ {
+ if (termination_signal)
+ {
+- g_debug ("Received %s signal.\n", sys_siglist[termination_signal]);
++ g_debug ("Received %s signal.\n", strsignal(termination_signal));
+ gsad_cleanup ();
+ /* Raise signal again, to exit with the correct return value. */
+ signal (termination_signal, SIG_DFL);
diff --git a/net-analyzer/greenbone-security-assistant/greenbone-security-assistant-9.0.1.ebuild b/net-analyzer/greenbone-security-assistant/greenbone-security-assistant-9.0.1.ebuild
index 552948dc9d4f..a0621ef26527 100644
--- a/net-analyzer/greenbone-security-assistant/greenbone-security-assistant-9.0.1.ebuild
+++ b/net-analyzer/greenbone-security-assistant/greenbone-security-assistant-9.0.1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -54,6 +54,8 @@ PATCHES=(
"${FILESDIR}/${PN}-8.0.1-node.patch"
# Remove ugly uninstall-snippet that causes failing re-emerge.
"${FILESDIR}/${P}-uninstall-snippet.patch"
+ # Replace deprecated glibc sys_siglist with strsignal
+ "${FILESDIR}/${P}-glibc_siglist.patch"
)
src_prepare() {