summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-python/autopep8/autopep8-1.3.2.ebuild11
-rw-r--r--dev-python/autopep8/autopep8-1.3.3.ebuild11
-rw-r--r--dev-python/autopep8/autopep8-9999.ebuild19
3 files changed, 28 insertions, 13 deletions
diff --git a/dev-python/autopep8/autopep8-1.3.2.ebuild b/dev-python/autopep8/autopep8-1.3.2.ebuild
index d26545d20f21..704659d6b880 100644
--- a/dev-python/autopep8/autopep8-1.3.2.ebuild
+++ b/dev-python/autopep8/autopep8-1.3.2.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
EAPI=6
@@ -10,11 +10,16 @@ inherit distutils-r1
DESCRIPTION="Automatically formats Python code to conform to the PEP 8 style guide"
HOMEPAGE="https://github.com/hhatto/autopep8 https://pypi.org/project/autopep8/"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+if [[ ${PV} == *9999* ]]; then
+ EGIT_REPO_URI="https://github.com/hhatto/${PN}.git"
+ inherit git-r3
+else
+ SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+ KEYWORDS="amd64 ~arm64 x86 ~amd64-linux ~x86-linux"
+fi
LICENSE="MIT"
SLOT="0"
-KEYWORDS="amd64 ~arm64 x86 ~amd64-linux ~x86-linux"
IUSE="test"
RDEPEND="
diff --git a/dev-python/autopep8/autopep8-1.3.3.ebuild b/dev-python/autopep8/autopep8-1.3.3.ebuild
index 48c985d0e5cd..86abf7bd303f 100644
--- a/dev-python/autopep8/autopep8-1.3.3.ebuild
+++ b/dev-python/autopep8/autopep8-1.3.3.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
EAPI=6
@@ -10,11 +10,16 @@ inherit distutils-r1
DESCRIPTION="Automatically formats Python code to conform to the PEP 8 style guide"
HOMEPAGE="https://github.com/hhatto/autopep8 https://pypi.org/project/autopep8/"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+if [[ ${PV} == *9999* ]]; then
+ EGIT_REPO_URI="https://github.com/hhatto/${PN}.git"
+ inherit git-r3
+else
+ SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+ KEYWORDS="~amd64 ~arm64 ~x86 ~amd64-linux ~x86-linux"
+fi
LICENSE="MIT"
SLOT="0"
-KEYWORDS="~amd64 ~arm64 ~x86 ~amd64-linux ~x86-linux"
IUSE="test"
RDEPEND="
diff --git a/dev-python/autopep8/autopep8-9999.ebuild b/dev-python/autopep8/autopep8-9999.ebuild
index 9b6187b0add6..1ebdd95ae114 100644
--- a/dev-python/autopep8/autopep8-9999.ebuild
+++ b/dev-python/autopep8/autopep8-9999.ebuild
@@ -1,20 +1,25 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-EAPI=5
-PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6} pypy pypy3 )
+EAPI=6
+
+PYTHON_COMPAT=( python{2_7,3_{4,5,6}} pypy{,3} )
PYTHON_REQ_USE="threads(+)"
-inherit distutils-r1 git-2
+inherit distutils-r1
DESCRIPTION="Automatically formats Python code to conform to the PEP 8 style guide"
HOMEPAGE="https://github.com/hhatto/autopep8 https://pypi.org/project/autopep8/"
-SRC_URI=""
-EGIT_REPO_URI="https://github.com/hhatto/${PN}.git"
+if [[ ${PV} == *9999* ]]; then
+ EGIT_REPO_URI="https://github.com/hhatto/${PN}.git"
+ inherit git-r3
+else
+ SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+ KEYWORDS="~amd64 ~arm64 ~x86 ~amd64-linux ~x86-linux"
+fi
LICENSE="MIT"
SLOT="0"
-KEYWORDS=""
IUSE="test"
RDEPEND="