summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-python/pyftpdlib/pyftpdlib-1.5.4.ebuild21
1 files changed, 15 insertions, 6 deletions
diff --git a/dev-python/pyftpdlib/pyftpdlib-1.5.4.ebuild b/dev-python/pyftpdlib/pyftpdlib-1.5.4.ebuild
index a5c7dac5aee0..a956577edbe4 100644
--- a/dev-python/pyftpdlib/pyftpdlib-1.5.4.ebuild
+++ b/dev-python/pyftpdlib/pyftpdlib-1.5.4.ebuild
@@ -48,15 +48,24 @@ python_compile_all() {
}
python_test() {
- # Skip tests which sometimes fail:
- # https://github.com/giampaolo/pyftpdlib/issues/470
- # https://github.com/giampaolo/pyftpdlib/issues/471
- py.test --ignore ${PN}/test/test_misc.py -k \
- "not (test_idle_data_timeout2 or test_on_incomplete_file_received)" \
- || die "Tests failed with ${EPYTHON}"
# These tests fail when passing additional options to py.test
# so we need to run them separately
py.test ${PN}/test/test_misc.py || die "Tests failed with ${EPYTHON}"
+ # Some of these tests tend to fail
+ local skipped_tests=(
+ # https://github.com/giampaolo/pyftpdlib/issues/470
+ # https://bugs.gentoo.org/659108
+ test_idle_data_timeout2
+ # https://github.com/giampaolo/pyftpdlib/issues/471
+ # https://bugs.gentoo.org/636410
+ test_on_incomplete_file_received
+ # https://github.com/giampaolo/pyftpdlib/issues/466
+ # https://bugs.gentoo.org/659786
+ test_nlst
+ )
+ skipped_tests=${skipped_tests[@]/%/ or}
+ py.test --ignore ${PN}/test/test_misc.py -k "not (${skipped_tests% or})" \
+ || die "Tests failed with ${EPYTHON}"
}
python_install_all() {