summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-03-23 09:23:16 +0100
committerMichał Górny <mgorny@gentoo.org>2021-03-23 09:39:09 +0100
commit623458be0b73cc9b89cbbcc7db81007ce1773378 (patch)
tree9ae217f92cad52b078005ee4c1a8d46780ad8153 /xfce-extra
parentdev-cpp/prometheus-cpp: remove unused patch(es) (diff)
downloadgentoo-623458be0b73cc9b89cbbcc7db81007ce1773378.tar.gz
gentoo-623458be0b73cc9b89cbbcc7db81007ce1773378.tar.bz2
gentoo-623458be0b73cc9b89cbbcc7db81007ce1773378.zip
xfce-extra/xfce4-systemload-plugin: Bump to 1.3.1
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'xfce-extra')
-rw-r--r--xfce-extra/xfce4-systemload-plugin/Manifest1
-rw-r--r--xfce-extra/xfce4-systemload-plugin/xfce4-systemload-plugin-1.3.1.ebuild47
2 files changed, 48 insertions, 0 deletions
diff --git a/xfce-extra/xfce4-systemload-plugin/Manifest b/xfce-extra/xfce4-systemload-plugin/Manifest
index 53479def38dd..08b81f70067a 100644
--- a/xfce-extra/xfce4-systemload-plugin/Manifest
+++ b/xfce-extra/xfce4-systemload-plugin/Manifest
@@ -1,2 +1,3 @@
DIST xfce4-systemload-plugin-1.2.4.tar.bz2 378644 BLAKE2B b50806925f02ce2a792cb72198bdd2cb0124e1d4ce12c91de124c9f4085e5908200a6f0c3b50fffdc1a6a5ae871eef0f04ec9687f43d8e8d5de1372d808a5fad SHA512 1f57ffe861e9906a1744a02b0b50b1dd9e755ea4d0f8b93dba7f42416cd3727834eca60129465fa6f665ac93ec43c3a5272ce9ceae5f4bb17bf180d88e87bddd
DIST xfce4-systemload-plugin-1.3.0.tar.bz2 399838 BLAKE2B 78e4db137665e26f02eb229629802e569144c4c6b3d05e272d1fbc1b9488c9f00d6c82953a70d94fd5d1e054071aa5768ecafd0daaca63d67c7e6811f0e22a04 SHA512 a82c58433c757a02ee068b036a2347c829ea9c3cf21f0db1e2fe6af229d4d51bb5014b8894d0fe57860e87b2fe5c21a18b77518114736f3a87801412694ba296
+DIST xfce4-systemload-plugin-1.3.1.tar.bz2 417959 BLAKE2B c9255349cb4f20a8d8165fbf5a124dbffcb4ca3633c32ca7b2cbbebc4770a50a24909158cd3fcaad9f8bab4b756b98b5329b60a1fbbd0ac0be13251bb950d542 SHA512 2b2285c5960a5728dd7818f90605848e462fe5fef8643ff5be64b7087225399395ace5ec8013f6795d410b0acf79ec77c14e2ed0e56007cfe6f13133ba708876
diff --git a/xfce-extra/xfce4-systemload-plugin/xfce4-systemload-plugin-1.3.1.ebuild b/xfce-extra/xfce4-systemload-plugin/xfce4-systemload-plugin-1.3.1.ebuild
new file mode 100644
index 000000000000..ebb39daf9da3
--- /dev/null
+++ b/xfce-extra/xfce4-systemload-plugin/xfce4-systemload-plugin-1.3.1.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit xdg-utils
+
+DESCRIPTION="System load plug-in for Xfce panel"
+HOMEPAGE="https://goodies.xfce.org/projects/panel-plugins/xfce4-systemload-plugin"
+SRC_URI="https://archive.xfce.org/src/panel-plugins/${PN}/${PV%.*}/${P}.tar.bz2"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux"
+IUSE="upower"
+
+RDEPEND=">=xfce-base/libxfce4ui-4.12:=[gtk3(+)]
+ >=xfce-base/xfce4-panel-4.12:=
+ >=xfce-base/xfconf-4.14:=
+ upower? ( >=sys-power/upower-0.9.23 )"
+DEPEND=${RDEPEND}
+BDEPEND="
+ dev-util/intltool
+ virtual/pkgconfig"
+
+src_configure() {
+ local myconf=(
+ # gtop is needed only as fallback when /proc is not available
+ --disable-libgtop
+ $(use_enable upower)
+ )
+
+ econf "${myconf[@]}"
+}
+
+src_install() {
+ default
+ find "${D}" -name '*.la' -delete || die
+}
+
+pkg_postinst() {
+ xdg_icon_cache_update
+}
+
+pkg_postrm() {
+ xdg_icon_cache_update
+}