summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-12-29 15:22:30 +0100
committerMichał Górny <mgorny@gentoo.org>2024-12-29 15:22:30 +0100
commit2ecd99796c9d898c5a583c0e948080c59d3e760a (patch)
tree47becbabe25405ad5c746e07a29bf7ed0666ff6b /xfce-extra
parentxfce-extra/xfce4-windowck-plugin: Bump to 0.5.2 (diff)
downloadgentoo-2ecd99796c9d898c5a583c0e948080c59d3e760a.tar.gz
gentoo-2ecd99796c9d898c5a583c0e948080c59d3e760a.tar.bz2
gentoo-2ecd99796c9d898c5a583c0e948080c59d3e760a.zip
xfce-extra/xfce4-xkb-plugin: Bump to 0.8.4
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'xfce-extra')
-rw-r--r--xfce-extra/xfce4-xkb-plugin/Manifest1
-rw-r--r--xfce-extra/xfce4-xkb-plugin/xfce4-xkb-plugin-0.8.4.ebuild64
2 files changed, 65 insertions, 0 deletions
diff --git a/xfce-extra/xfce4-xkb-plugin/Manifest b/xfce-extra/xfce4-xkb-plugin/Manifest
index 8d4df7cb440f..f1d612c2d037 100644
--- a/xfce-extra/xfce4-xkb-plugin/Manifest
+++ b/xfce-extra/xfce4-xkb-plugin/Manifest
@@ -1 +1,2 @@
DIST xfce4-xkb-plugin-0.8.3.tar.bz2 864177 BLAKE2B 4c4c5ab781265e50ddb14210566f608e2798f881d4b06e7e8f121c466ea0eebb694cf394b0bec747b7a5f1f99962ee1d014f29f077ef877e8063c23934eff1b4 SHA512 02ae82a1e01b7cc54154545c6ff42a450a81ba44697620ebb716a663300ea08fbf6ccafc5fd4d710791f142e1c249f17b613d90ffd99025ad97dfa0230ee55b2
+DIST xfce4-xkb-plugin-0.8.4.tar.bz2 1002966 BLAKE2B 76bea1c9ff6b59c847f88bfee0006730961a1f09871f07a0c60ff181cbeeb6b76728217aa213be72888bf7f08ba71b70ef27fa2fe4acef5d1600fff4e7d1da50 SHA512 1a5d3500121e78f7c85b6baa1e8df0ff62c2d1ccd22c09779ff97a796eea924a1e2c7244d291b3c7822772754c275560c4f1bf53cc65fc9298d09cf87b79b140
diff --git a/xfce-extra/xfce4-xkb-plugin/xfce4-xkb-plugin-0.8.4.ebuild b/xfce-extra/xfce4-xkb-plugin/xfce4-xkb-plugin-0.8.4.ebuild
new file mode 100644
index 000000000000..c8c52cc06032
--- /dev/null
+++ b/xfce-extra/xfce4-xkb-plugin/xfce4-xkb-plugin-0.8.4.ebuild
@@ -0,0 +1,64 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit xdg-utils
+
+DESCRIPTION="XKB layout switching panel plug-in for the Xfce desktop environment"
+HOMEPAGE="
+ https://docs.xfce.org/panel-plugins/xfce4-xkb-plugin
+ https://gitlab.xfce.org/panel-plugins/xfce4-xkb-plugin/
+"
+SRC_URI="https://archive.xfce.org/src/panel-plugins/${PN}/${PV%.*}/${P}.tar.bz2"
+
+LICENSE="BSD-2 GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ppc ~ppc64 ~riscv ~sparc ~x86 ~amd64-linux ~x86-linux"
+IUSE="libnotify"
+
+DEPEND="
+ >=dev-libs/glib-2.50.0
+ >=gnome-base/librsvg-2.40
+ >=x11-libs/gtk+-3.22.0:3
+ >=x11-libs/libwnck-3.14:3
+ x11-libs/libX11
+ >=x11-libs/libxklavier-5.3
+ >=xfce-base/garcon-4.16.0:=
+ >=xfce-base/libxfce4ui-4.16.0:=
+ >=xfce-base/libxfce4util-4.16.0:=
+ >=xfce-base/xfce4-panel-4.16.0:=
+ >=xfce-base/xfconf-4.16.0:=
+ libnotify? ( >=x11-libs/libnotify-0.7.0 )
+"
+RDEPEND="
+ ${DEPEND}
+ x11-apps/setxkbmap
+ >=xfce-base/xfce4-settings-4.11
+"
+BDEPEND="
+ >=sys-devel/gettext-0.19.8
+ virtual/pkgconfig
+"
+
+src_configure() {
+ local myconf=(
+ --libexecdir="${EPREFIX}"/usr/$(get_libdir)
+ $(use_enable libnotify)
+ )
+
+ econf "${myconf[@]}"
+}
+
+src_install() {
+ default
+ find "${D}" -name '*.la' -delete || die
+}
+
+pkg_postinst() {
+ xdg_icon_cache_update
+}
+
+pkg_postrm() {
+ xdg_icon_cache_update
+}