summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-05-16 16:22:49 +0200
committerMichał Górny <mgorny@gentoo.org>2024-05-16 16:58:45 +0200
commitb5cb644024a60c9b93ad28aef5da45dab8f3ed37 (patch)
tree324fd849ebb86b8563c43e617df4fcdfcfe366ee /xfce-base
parentsys-devel/llvm: Backport -march=native fix (diff)
downloadgentoo-b5cb644024a60c9b93ad28aef5da45dab8f3ed37.tar.gz
gentoo-b5cb644024a60c9b93ad28aef5da45dab8f3ed37.tar.bz2
gentoo-b5cb644024a60c9b93ad28aef5da45dab8f3ed37.zip
xfce-base/xfce4-panel: Bump to 4.19.4
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'xfce-base')
-rw-r--r--xfce-base/xfce4-panel/Manifest1
-rw-r--r--xfce-base/xfce4-panel/xfce4-panel-4.19.4.ebuild84
2 files changed, 85 insertions, 0 deletions
diff --git a/xfce-base/xfce4-panel/Manifest b/xfce-base/xfce4-panel/Manifest
index c9705357cac6..8c7d40985265 100644
--- a/xfce-base/xfce4-panel/Manifest
+++ b/xfce-base/xfce4-panel/Manifest
@@ -1,2 +1,3 @@
DIST xfce4-panel-4.18.6.tar.bz2 1595352 BLAKE2B e4f4eb2f3838cde69a2614021be184ba7281910e595cc868180eba5ce40898fb538cb82ef5317f8316273b6a926553e051730e4918f3d2d339e03729ac8c2a85 SHA512 a1c4597bbbb72d2f3ef90abe0082abe3404e0ea7fa6027e26ca50e31e03645464ce3e0a72f4d927e84c5775a775e3a70f70e25bd3d2e4358da869f9c474e6174
DIST xfce4-panel-4.19.3.tar.bz2 2187643 BLAKE2B d6b597a8abb1d8a079315ccb386797fb98c4bdd332bbafacfcdc5965f528eeb34ff99a08f4c9abaa57be60bc642d164ef11a69b7a847cdeeebfded3ca2ccdedc SHA512 4d7912052bc4dae50fe1d32503987636d8579baa75313f038c647ba3c4662da63c4317ffa9cda3d0188d3e05357df038f739217f2a3f64d7151d8f8c9af261b7
+DIST xfce4-panel-4.19.4.tar.bz2 2237827 BLAKE2B 2f302a665c875cebf3d1017b13b658654bc9c0f1d498bc55e6d1fde036f2919759a9a77cbd06567796c43f34ce27d198391c10eed3c40907626a275e788e4b19 SHA512 c02d20931ec53817676a7c1c48b91075d79fbfd64ca0ecfe8d581d4206e86d7fb4893bcb8c2bd1e1bdf5040da0077e82a51988681928327fc791232af134fc8b
diff --git a/xfce-base/xfce4-panel/xfce4-panel-4.19.4.ebuild b/xfce-base/xfce4-panel/xfce4-panel-4.19.4.ebuild
new file mode 100644
index 000000000000..6329f2e10d87
--- /dev/null
+++ b/xfce-base/xfce4-panel/xfce4-panel-4.19.4.ebuild
@@ -0,0 +1,84 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit vala xdg-utils
+
+DESCRIPTION="Panel for the Xfce desktop environment"
+HOMEPAGE="
+ https://docs.xfce.org/xfce/xfce4-panel/start
+ https://gitlab.xfce.org/xfce/xfce4-panel/
+"
+SRC_URI="https://archive.xfce.org/src/xfce/${PN}/${PV%.*}/${P}.tar.bz2"
+
+LICENSE="GPL-2+ LGPL-2.1+"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~mips ~ppc ~ppc64 ~riscv ~sparc ~x86"
+IUSE="+dbusmenu introspection vala wayland X"
+REQUIRED_USE="
+ || ( wayland X )
+ vala? ( introspection )
+"
+
+DEPEND="
+ >=dev-libs/glib-2.72.0
+ >=x11-libs/cairo-1.16.0
+ >=x11-libs/gtk+-3.24.0:3[X?,introspection?,wayland?]
+ >=xfce-base/exo-0.11.2:=
+ >=xfce-base/garcon-4.17.0:=
+ >=xfce-base/libxfce4ui-4.17.1:=
+ >=xfce-base/libxfce4util-4.17.2:=[introspection?,vala?]
+ >=xfce-base/libxfce4windowing-4.19.3:=[X?]
+ >=xfce-base/xfconf-4.13.2:=
+ dbusmenu? ( >=dev-libs/libdbusmenu-16.04.0[gtk3] )
+ introspection? ( >=dev-libs/gobject-introspection-1.66:= )
+ wayland? (
+ >=dev-libs/wayland-1.15
+ >=gui-libs/gtk-layer-shell-0.7.0
+ )
+ X? (
+ >=x11-libs/libX11-1.6.7
+ x11-libs/libwnck:3
+ )
+"
+RDEPEND="
+ ${DEPEND}
+"
+BDEPEND="
+ vala? ( $(vala_depend) )
+ dev-lang/perl
+ dev-util/gdbus-codegen
+ dev-util/intltool
+ sys-devel/gettext
+ virtual/pkgconfig
+"
+
+src_configure() {
+ local myconf=(
+ $(use_enable introspection)
+ $(use_enable dbusmenu dbusmenu-gtk3)
+ $(use_enable vala)
+ $(use_enable wayland)
+ $(use_enable wayland gtk-layer-shell)
+ $(use_enable X x11)
+ )
+
+ use vala && vala_setup
+ econf "${myconf[@]}"
+}
+
+src_install() {
+ default
+ find "${D}" -name '*.la' -delete || die
+}
+
+pkg_postinst() {
+ xdg_icon_cache_update
+ xdg_desktop_database_update
+}
+
+pkg_postrm() {
+ xdg_icon_cache_update
+ xdg_desktop_database_update
+}