summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-06-03 12:11:24 +0200
committerMichał Górny <mgorny@gentoo.org>2020-06-03 12:23:59 +0200
commit358fa544c31daa667725a389bced6d6c8a536fe1 (patch)
treed1bd0e8a6903f74591bddefabff06a6c5b23a9ee /xfce-base/exo
parentdev-util/perf: version bump to 5.7 (diff)
downloadgentoo-358fa544c31daa667725a389bced6d6c8a536fe1.tar.gz
gentoo-358fa544c31daa667725a389bced6d6c8a536fe1.tar.bz2
gentoo-358fa544c31daa667725a389bced6d6c8a536fe1.zip
xfce-base/exo: Backport parallel make fix
Closes: https://bugs.gentoo.org/725882 Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'xfce-base/exo')
-rw-r--r--xfce-base/exo/exo-4.15.1.ebuild4
-rw-r--r--xfce-base/exo/files/exo-4.15.1-parallel-make.patch66
2 files changed, 70 insertions, 0 deletions
diff --git a/xfce-base/exo/exo-4.15.1.ebuild b/xfce-base/exo/exo-4.15.1.ebuild
index 5089b190c4c8..1f9eb2e523e7 100644
--- a/xfce-base/exo/exo-4.15.1.ebuild
+++ b/xfce-base/exo/exo-4.15.1.ebuild
@@ -25,6 +25,10 @@ DEPEND="${RDEPEND}
sys-devel/gettext
virtual/pkgconfig"
+PATCHES=(
+ "${FILESDIR}"/exo-4.15.1-parallel-make.patch
+)
+
src_install() {
default
find "${D}" -name '*.la' -delete || die
diff --git a/xfce-base/exo/files/exo-4.15.1-parallel-make.patch b/xfce-base/exo/files/exo-4.15.1-parallel-make.patch
new file mode 100644
index 000000000000..f18159442fea
--- /dev/null
+++ b/xfce-base/exo/files/exo-4.15.1-parallel-make.patch
@@ -0,0 +1,66 @@
+From d3f3232eb53a052711029d2fafc36e23da971b35 Mon Sep 17 00:00:00 2001
+From: Romain Bouvier <skunnyk@alteroot.org>
+Date: Fri, 29 May 2020 11:11:41 +0200
+Subject: [PATCH] exo-29: Fix race condition in make install
+
+- Since the exo drop of gtk2, HEADERS are declared twice, which can lead
+ to race conditions when using parallel make "make -j4 install"
+- Simplify Makefile to only have one HEADERS section
+- This fix #29
+---
+ exo/Makefile.am | 24 ++++--------------------
+ 1 file changed, 4 insertions(+), 20 deletions(-)
+
+diff --git a/exo/Makefile.am b/exo/Makefile.am
+index fc8845d4..358ae9cb 100644
+--- a/exo/Makefile.am
++++ b/exo/Makefile.am
+@@ -23,30 +23,14 @@ libexo_headers = \
+ exo-tree-view.h \
+ exo-utils.h
+
+-libexo_built_public_sources = \
+- exo-enum-types.h
+-
+-libexo_built_sources = \
+- $(libexo_built_public_sources) \
++libexo_2_built_sources = \
++ exo-enum-types.h \
+ exo-alias.h \
+ exo-aliasdef.c \
+ exo-enum-types.c \
+ exo-marshal.c \
+ exo-marshal.h
+
+-libexoincludedir = $(includedir)/exo-2/exo
+-
+-libexoinclude_HEADERS = \
+- $(libexo_built_public_sources) \
+- $(libexo_headers) \
+- exo.h \
+- exo-config.h
+-
+-
+-##
+-## GTK+ 3 support library
+-##
+-
+ libexo_2_includedir = $(includedir)/exo-2/exo
+
+ lib_LTLIBRARIES = libexo-2.la
+@@ -141,10 +125,10 @@ CLEANFILES = \
+ DISTCLEANFILES = \
+ stamp-exo-enum-types.h \
+ stamp-exo-marshal.h \
+- $(libexo_built_sources)
++ $(libexo_2_built_sources)
+
+ BUILT_SOURCES = \
+- $(libexo_built_sources)
++ $(libexo_2_built_sources)
+
+ exo-alias.h: make-exo-alias.pl exo.symbols
+ $(AM_V_GEN) $(PERL) $(srcdir)/make-exo-alias.pl < $(srcdir)/exo.symbols > exo-alias.h
+--
+2.26.2
+