summaryrefslogtreecommitdiff
path: root/x11-wm
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2018-09-18 16:40:12 -0400
committerTim Harder <radhermit@gentoo.org>2018-09-18 17:21:47 -0400
commit7c53949742780e1d490029b6702812e43200bc2a (patch)
tree6234c063eb0a99b31e9cdd27fa610534121c3620 /x11-wm
parentdev-python/xvfbwrapper: version bump to 0.2.9 (diff)
downloadgentoo-7c53949742780e1d490029b6702812e43200bc2a.tar.gz
gentoo-7c53949742780e1d490029b6702812e43200bc2a.tar.bz2
gentoo-7c53949742780e1d490029b6702812e43200bc2a.zip
x11-wm/qtile: version bump to 0.12.0
Fixes: https://bugs.gentoo.org/616914
Diffstat (limited to 'x11-wm')
-rw-r--r--x11-wm/qtile/Manifest1
-rw-r--r--x11-wm/qtile/files/qtile-0.12.0-tests.patch15
-rw-r--r--x11-wm/qtile/qtile-0.12.0.ebuild67
-rw-r--r--x11-wm/qtile/qtile-9999.ebuild18
4 files changed, 97 insertions, 4 deletions
diff --git a/x11-wm/qtile/Manifest b/x11-wm/qtile/Manifest
index 1289b157f850..63002bfde7a9 100644
--- a/x11-wm/qtile/Manifest
+++ b/x11-wm/qtile/Manifest
@@ -1,2 +1,3 @@
DIST qtile-0.10.5.tar.gz 325311 BLAKE2B fadf8c232d6f3840f93d61d4c8c6a2dddc61483e316b02f7a60058eac0e5da9f3b2eab99e952b7db30e29036d2db0283e07926ec054322994ebaf16a7a223906 SHA512 00fbeaa17921eb2d4014c979bcd1f81f22e155606b13340f4653c262d7fde3b1f471a7f20e9a80b58435bdc1e5479c983a72e4be180b49df2ef4a5fe568b8631
DIST qtile-0.10.6.tar.gz 328892 BLAKE2B 3a4887808b87b0cbe4410d2bac8af4664873d2aa9b8c782f8c026ae78ba586b6e02d9a50ee42434afa916e9fe9041a7a15a68f9026ee7d95a0edec2594515cfa SHA512 39eef26358e1220ca766b030733396206df68677e3f23d6847d375f479952a4e2d47e0c3e59fab2e5046e899bad91d107a913bb25458fb66859dec3fa8c0e956
+DIST qtile-0.12.0.tar.gz 447139 BLAKE2B c1bea9ba8b36ccf14b7e55b4a2cbc05714ecffef33d992e9bf1683e6f8c416d481cf9d141bbf0fe62df65aeb3555290647d072dd45f507b08e0d523f992a1671 SHA512 a94237c40775524e16aebdd8555d0ed0623c248b65aee32851145e8a6cc54ce4d46ee5cf4c4f583e468de4557a565c4281660219e4b2ee1b73fb483567e1a5b2
diff --git a/x11-wm/qtile/files/qtile-0.12.0-tests.patch b/x11-wm/qtile/files/qtile-0.12.0-tests.patch
new file mode 100644
index 000000000000..8443381b1766
--- /dev/null
+++ b/x11-wm/qtile/files/qtile-0.12.0-tests.patch
@@ -0,0 +1,15 @@
+The '~' character doesn't expand to $HOME in all build envs.
+
+--- qtile-0.12.0/test/test_bar.py
++++ qtile-0.12.0/test/test_bar.py
+@@ -105,8 +105,8 @@
+ assert c.complete("/bi") == "/bin/"
+ c.reset()
+ assert c.complete("/bin") != "/bin/"
+- c.reset()
+- assert c.complete("~") != "~"
++ #c.reset()
++ #assert c.complete("~") != "~"
+
+ c.reset()
+ s = "thisisatotallynonexistantpathforsure"
diff --git a/x11-wm/qtile/qtile-0.12.0.ebuild b/x11-wm/qtile/qtile-0.12.0.ebuild
new file mode 100644
index 000000000000..5ba9a0932049
--- /dev/null
+++ b/x11-wm/qtile/qtile-0.12.0.ebuild
@@ -0,0 +1,67 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6} )
+
+inherit distutils-r1 virtualx
+
+if [[ ${PV} == 9999* ]] ; then
+ EGIT_REPO_URI="https://github.com/qtile/qtile.git"
+ inherit git-r3
+else
+ SRC_URI="https://github.com/qtile/qtile/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+DESCRIPTION="A full-featured, hackable tiling window manager written in Python"
+HOMEPAGE="http://qtile.org/"
+
+LICENSE="MIT"
+SLOT="0"
+IUSE="test"
+# docs require sphinxcontrib-blockdiag and sphinxcontrib-seqdiag
+
+RDEPEND="
+ x11-libs/cairo[xcb]
+ x11-libs/pango
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ >=dev-python/cairocffi-0.7[${PYTHON_USEDEP}]
+ >=dev-python/cffi-1.1.0[${PYTHON_USEDEP}]
+ >=dev-python/six-1.4.1[${PYTHON_USEDEP}]
+ >=dev-python/xcffib-0.5.0[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep 'dev-python/trollius[${PYTHON_USEDEP}]' 'python2*')
+"
+DEPEND="${RDEPEND}
+ test? (
+ dev-python/pytest[${PYTHON_USEDEP}]
+ dev-python/pytest-cov[${PYTHON_USEDEP}]
+ dev-python/xvfbwrapper[${PYTHON_USEDEP}]
+ x11-base/xorg-server[xephyr]
+ x11-apps/xeyes
+ x11-apps/xcalc
+ x11-apps/xclock
+ )
+"
+
+# display retry backoff slowness and failures
+RESTRICT="test"
+
+PATCHES=( "${FILESDIR}"/${PN}-0.12.0-tests.patch )
+
+python_test() {
+ # force usage of built module
+ rm -rf "${S}"/libqtile || die
+ PYTHONPATH="${BUILD_DIR}/lib" py.test -v "${S}"/test || die "tests failed under ${EPYTHON}"
+}
+
+python_install_all() {
+ local DOCS=( CHANGELOG README.rst )
+ distutils-r1_python_install_all
+
+ insinto /usr/share/xsessions
+ doins resources/qtile.desktop
+
+ exeinto /etc/X11/Sessions
+ newexe "${FILESDIR}"/${PN}-session ${PN}
+}
diff --git a/x11-wm/qtile/qtile-9999.ebuild b/x11-wm/qtile/qtile-9999.ebuild
index fc96c05526ee..5ba9a0932049 100644
--- a/x11-wm/qtile/qtile-9999.ebuild
+++ b/x11-wm/qtile/qtile-9999.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2016 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
EAPI=6
@@ -34,15 +34,25 @@ RDEPEND="
"
DEPEND="${RDEPEND}
test? (
- dev-python/nose[${PYTHON_USEDEP}]
- x11-base/xorg-server[kdrive]
+ dev-python/pytest[${PYTHON_USEDEP}]
+ dev-python/pytest-cov[${PYTHON_USEDEP}]
+ dev-python/xvfbwrapper[${PYTHON_USEDEP}]
+ x11-base/xorg-server[xephyr]
+ x11-apps/xeyes
+ x11-apps/xcalc
+ x11-apps/xclock
)
"
+# display retry backoff slowness and failures
RESTRICT="test"
+PATCHES=( "${FILESDIR}"/${PN}-0.12.0-tests.patch )
+
python_test() {
- VIRTUALX_COMMAND="nosetests" virtualmake
+ # force usage of built module
+ rm -rf "${S}"/libqtile || die
+ PYTHONPATH="${BUILD_DIR}/lib" py.test -v "${S}"/test || die "tests failed under ${EPYTHON}"
}
python_install_all() {