summaryrefslogtreecommitdiff
path: root/x11-wm
diff options
context:
space:
mode:
authorMichael Mair-Keimberger <mmk@levelnine.at>2024-07-19 20:54:08 +0200
committerYixun Lan <dlan@gentoo.org>2024-07-21 07:33:30 +0000
commit402b8536af6b75238d5bd23b7ad0cae2e9fbbf4c (patch)
treea5fb05141a46bc5b04d0c54f7c1a5ed694080366 /x11-wm
parentdev-util/bpftool: fix overriding of PV in 7.5.0 (diff)
downloadgentoo-402b8536af6b75238d5bd23b7ad0cae2e9fbbf4c.tar.gz
gentoo-402b8536af6b75238d5bd23b7ad0cae2e9fbbf4c.tar.bz2
gentoo-402b8536af6b75238d5bd23b7ad0cae2e9fbbf4c.zip
x11-wm/e16: add 1.0.29
Closes: https://bugs.gentoo.org/910443 Closes: https://github.com/gentoo/gentoo/pull/37622 Signed-off-by: Michael Mair-Keimberger <mmk@levelnine.at> Signed-off-by: Yixun Lan <dlan@gentoo.org>
Diffstat (limited to 'x11-wm')
-rw-r--r--x11-wm/e16/Manifest1
-rw-r--r--x11-wm/e16/e16-1.0.29.ebuild146
2 files changed, 147 insertions, 0 deletions
diff --git a/x11-wm/e16/Manifest b/x11-wm/e16/Manifest
index 5ccaefc97367..a31ae1a0d0f1 100644
--- a/x11-wm/e16/Manifest
+++ b/x11-wm/e16/Manifest
@@ -1 +1,2 @@
DIST e16-1.0.25.tar.xz 1400004 BLAKE2B 34ef7be6896d04234b3a48675c185aa86d7a70e0e8b5db2cdf15bef4336a40575065713f9612b94dd29a490902f36f9eb08489a779160801e885a5635d896e56 SHA512 e5cc6b08ddad8eb3052dbafda2a0ab56134e90eb9cdf75da405ac853301eadf8348dc918218119117a1f96d08e562367ff60365deb790a14af5fbdaaf89684d3
+DIST e16-1.0.29.tar.xz 1410672 BLAKE2B 5b96a13ed6ec70d01772cade4d85caf39f6b156a48a6778a9312cce4c9ade95f5c77d991de4d9128fff27abb7cc78add08930615031117c6b0791ddb5743553d SHA512 930fd97c125e85cca6ee4cb1eae350219721d9e96824f2147fedfcd4050596e603ed174789faaf23b1265671e18d1717eba6a3dae7e4fa944bf7eff01b707a4c
diff --git a/x11-wm/e16/e16-1.0.29.ebuild b/x11-wm/e16/e16-1.0.29.ebuild
new file mode 100644
index 000000000000..ffa8ee7715a8
--- /dev/null
+++ b/x11-wm/e16/e16-1.0.29.ebuild
@@ -0,0 +1,146 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DESCRIPTION="Enlightenment Window Manager (E16)"
+HOMEPAGE="https://www.enlightenment.org https://sourceforge.net/projects/enlightenment/"
+SRC_URI="https://downloads.sourceforge.net/enlightenment/${P}.tar.xz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="+alsa audiofile dbus debug +dialogs doc examples gnome
+libhack modules nls no-container opengl +pango +poll player
+pulseaudio select +sndfile sound +themes xcomposite +xft xi2
+xinerama xpresent +xrandr +xrender +xsm +xsync zoom"
+
+REQUIRED_USE="
+ ^^ ( poll select )
+ opengl? ( xcomposite )
+ pango? ( xft )
+ sound? (
+ ^^ ( alsa player pulseaudio )
+ alsa? ( ^^ ( sndfile audiofile ) )
+ pulseaudio? ( ^^ ( sndfile audiofile ) )
+ )
+"
+
+BDEPEND="
+ nls? ( sys-devel/gettext )
+ virtual/pkgconfig
+"
+COMMON_DEPEND="
+ media-libs/freetype:2
+ media-libs/imlib2[X]
+ virtual/libiconv
+ x11-libs/libX11
+ x11-libs/libXext
+ x11-misc/xbitmaps
+ dbus? ( sys-apps/dbus )
+ opengl? (
+ media-libs/glu
+ media-libs/mesa
+ )
+ pango? (
+ dev-libs/glib:2
+ x11-libs/pango[X]
+ )
+ sound? (
+ alsa? ( media-libs/alsa-lib )
+ player? ( media-sound/alsa-utils )
+ pulseaudio? ( || (
+ media-libs/libpulse
+ media-sound/apulse[sdk]
+ ) )
+ audiofile? ( media-libs/audiofile:= )
+ sndfile? ( media-libs/libsndfile )
+ )
+ xcomposite? (
+ x11-libs/libXcomposite
+ x11-libs/libXdamage
+ x11-libs/libXfixes
+ )
+ xft? ( x11-libs/libXft )
+ xinerama? ( x11-libs/libXinerama )
+ xpresent? ( x11-libs/libXpresent )
+ xrandr? ( x11-libs/libXrandr )
+ xrender? ( x11-libs/libXrender )
+ xsm? (
+ x11-libs/libICE
+ x11-libs/libSM
+ )
+ zoom? ( x11-libs/libXxf86vm )
+"
+RDEPEND="${COMMON_DEPEND}
+ doc? ( app-doc/e16-docs )
+ nls? ( virtual/libintl )
+ themes? ( x11-themes/e16-themes )
+ !x11-wm/enlightenment:0
+"
+DEPEND="${COMMON_DEPEND}
+ x11-base/xorg-proto
+"
+
+src_configure() {
+ local myconf=(
+ $(use_enable dbus)
+ $(use_enable debug libtrip)
+ $(use_enable dialogs)
+ $(use_enable doc docs)
+ $(use_enable libhack)
+ $(use_enable modules)
+ $(use_enable nls)
+ $(use_enable no-container containerless)
+ $(use_enable opengl glx)
+ $(use_enable pango)
+ $(use_enable xcomposite composite)
+ $(use_enable xft)
+ $(use_enable xi2)
+ $(use_enable xinerama)
+ $(use_enable xpresent)
+ $(use_enable xrandr)
+ $(use_enable xrender)
+ $(use_enable xsm sm)
+ $(use_enable xsync)
+ $(use_enable zoom)
+ $(use_with gnome gnome gnome3)
+ --enable-mans
+ --disable-docs
+ --disable-esdtest
+ --disable-gcc-cpp
+ --disable-werror
+ --disable-xscrnsaver
+ )
+ if use sound; then
+ use alsa && myconf+=( --enable-sound=alsa )
+ use pulseaudio && myconf+=( --enable-sound=pulseaudio )
+ use player && myconf+=( --enable-sound=player )
+
+ if use alsa || use pulseaudio; then
+ use sndfile && myconf+=( --with-sndldr=sndfile )
+ use audiofile && myconf+=( --with-sndldr=audiofile )
+ else
+ myconf+=( --without-sndldr )
+ fi
+ else
+ myconf+=( --disable-sound --without-sndldr )
+ fi
+ use poll && myconf+=( --with-evhan=poll )
+ use select && myconf+=( --with-evhan=select )
+
+ econf "${myconf[@]}"
+}
+
+src_install() {
+ default
+ docompress -x /usr/share/doc/${PF}/e16.html
+ dodoc COMPLIANCE docs/e16.html
+ use examples && dodoc -r sample-scripts
+}
+
+pkg_postinst() {
+ einfo "In order to use custom fonts, put them into ~/.e16/fonts/ and use"
+ einfo "appropriate names in ~/.e16/fonts.cfg. \"Use theme font configuration\""
+ einfo "in the Theme setting should be disabled for this to work."
+}