summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLouis Regnier <louregni@student.42.fr>2021-08-25 21:49:26 +0200
committerJoonas Niilola <juippis@gentoo.org>2021-09-02 09:53:07 +0300
commit25b64bc765cb1519aa819afaa96fa9b4b3da4cfc (patch)
tree6c9cb4bbda39b63114f675105cb29516d2ffa14f /x11-terms/kitty-terminfo/kitty-terminfo-0.23.1.ebuild
parentapp-emulation/virt-viewer: add BDEPEND, update deps (diff)
downloadgentoo-25b64bc765cb1519aa819afaa96fa9b4b3da4cfc.tar.gz
gentoo-25b64bc765cb1519aa819afaa96fa9b4b3da4cfc.tar.bz2
gentoo-25b64bc765cb1519aa819afaa96fa9b4b3da4cfc.zip
x11-terms/kitty-terminfo: bump to 0.23.1
Signed-off-by: Louis Regnier <louregni@student.42.fr> Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'x11-terms/kitty-terminfo/kitty-terminfo-0.23.1.ebuild')
-rw-r--r--x11-terms/kitty-terminfo/kitty-terminfo-0.23.1.ebuild41
1 files changed, 41 insertions, 0 deletions
diff --git a/x11-terms/kitty-terminfo/kitty-terminfo-0.23.1.ebuild b/x11-terms/kitty-terminfo/kitty-terminfo-0.23.1.ebuild
new file mode 100644
index 000000000000..be10def6c282
--- /dev/null
+++ b/x11-terms/kitty-terminfo/kitty-terminfo-0.23.1.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{7,8,9} )
+
+inherit python-any-r1 toolchain-funcs xdg
+
+DESCRIPTION="Terminfo for kitty, an OpenGL-based terminal emulator"
+HOMEPAGE="https://github.com/kovidgoyal/kitty"
+SRC_URI="https://github.com/kovidgoyal/kitty/releases/download/v${PV}/kitty-${PV}.tar.xz"
+S="${WORKDIR}/kitty-${PV}"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="debug"
+
+DEPEND="${PYTHON_DEPS}"
+
+PATCHES=(
+ "${FILESDIR}"/kitty-terminfo-setup-0.20.1.patch
+)
+
+# kitty-terminfo is a split package from kitty that only installs the terminfo
+# file. As tests are designed to be run with the whole package compiled they
+# would fail in this case.
+RESTRICT="test"
+
+src_compile() {
+ "${EPYTHON}" setup.py \
+ --verbose $(usex debug --debug "") \
+ --libdir-name $(get_libdir) \
+ linux-terminfo || die "Failed to compile kitty."
+}
+
+src_install() {
+ insinto /usr
+ doins -r linux-package/*
+}